I once over-estimated my knowledge of hardware (especially combination of motherboard and memory) and bought 4x 16GB GeIL EVO Potenza DDR4-3000 DIMM CL16 for an ASRock X99 Extreme3. I tried to configure it myself, but I never got the forth memory bar to be recognized and the Ubuntu system thus had only 12 of 16 GB available memory.

Then, I brought the PC to a professional for some repairs and asked that the configuration ought to be checked. He indeed succeeded to configure the UEFI to make all 4 bars work with a maximum frequence of approx. half of the 3000MHz available (I think 1600).

Now, I left the PC turned off for some months and the UEFI settings got erased. I forgot that that happens... Now, I'd like to find these settings again to save myself the way to the store and maybe learn something about memory configuration.

The product details from the sellers homepage (translated):

Model name:     EVO Potenza
Capacity:   16GB
# of modules:   4x
Capacity of each module:    4096MB
Type of memory:     DDR4-3000
JEDEC Norm:     PC4-24000U
Memory type:    unbuffered
Norm:   DIMM
Memory interface:   DDR4
Max. Frequency:     3000MHz
Voltage:    1.35V
Connection:     288-pin
Latency (CL):   CL16
RAS to CAS Delay (tRCD):    16
Ras Precharge Time (tRP):   16
Row Active Time (tRAS):     36
Features:   XMP 2.0 Support

I have the following options available in the UEFI (version 3.70):

BCLK Frequency
DRAM Voltage
DRAM Reference Clock
DRAM Frequency (Auto | DDR4-800 | DDR4-1066 | DDR4-1333 | DDR4-1600)

Primary Timing Options:
CAS# Latency (tCL)
RAS# to CAS# Delay (TRCD)
Raw Percentage Time (tRP)
RAS# Active Time (tRAS)
Command Rate (CR)

Secondary Timing Options:
Write Recovery Time (tWR)
Refresh Cycle Time (tRFC)
RAS to RAS Delay (tRRD)
RAS to RAS Delay (tRRD_L)
Write to Read Delay (tWTR)
Write to Read Delay (tWTR_L)
Read to Percentage (tRTP)
Four Activate Window (tFAW)
CAS Write Latency (tCWL)

Third Timing Options and Advanced Settings
[I can list them if that if that helps]

I already tried to set all options available from the product details which still causes only 3 of 4 bars to be recognized.

The CPU is Intel(R) XEON(R) CPU E5-2603 v3 @ 1.60GHz. The OS is now Ubuntu 18.04 (in case that matters, the memory is already not recognized in the UEFI).

16GB of RAM installed, ~12GB useable is marked as duplicate of question regarding Windows which has never been involved in my system or an erroneous connection of the memory or CPU socket which I believe is unlikely since the problem is identical to the situation before the first fix which needs to be found again (unfortunately and because of my bad).

  • 1) EFI settings getting erased when the machine is powered off for a long time is not normal. You might have another problem (e.g. an empty battery on the motherboard).
    – Hennes
    Aug 25, 2018 at 16:44
  • 2). DR stands for double data rate. a 200MHz DDR DIMM trafers data just as fast as a 400MHz non DDR DIMM. Could it be that you try to significantly overclock your memory to 6000 Marketing MHz?
    – Hennes
    Aug 25, 2018 at 16:48
  • @Hennes Thanks for input. 1.) The machine was off for approx. 8 months. I installed an UEFI update some days ago, but the settings were gone already when I started the machine for the first time after the long timeout. 2). The thing is that I don't really know what I'm doing, so I might try that unintentionally, but it's not my aim - which is only to get the 16GB running again. The only thing I did was to change the settings which I recognized in the product data sheet. Aug 25, 2018 at 18:19
  • From your post "Features: XMP 2.0 Unterstützung". Can you test with with XMP disabled? XMP is intel eXtreem Memory Profile, best used when you only add 2 DIMMS rather than 4, so not sure why it would then work with 3/4,.... Worth testing though.
    – Hennes
    Aug 25, 2018 at 18:21
  • @Hennes I went through all the settings and there's no option to dis/enable extreme memory. There's an option to dis/enable Intel SpeedStep Technology. Aug 25, 2018 at 18:43

3 Answers 3


I payed an IT guy to figure it out and he simply pulled and plugged bars from the 3rd and 4th bench with reboots in between. That, he said approximately, triggers the auto-configuration of quad-channel mode.

The sequence was as I recall, insertion of one in the 3rd bench, reboot, check the recognition in the EFI menu, shutdown, put that one in the 4th bench, then reboot, check, shutdown, put the 4th bar in the 3rd bench. And reboot. And that was it. The 4 bars where recognized and operate with 2400MHz and I have 16GB RAM which was all I ever wanted, except for buying the right modules in the first place.

I did reset the memory settings (timing etc.) before he started. And he checked the bars for marks indicating the order, but there were none.


The RAM counseled for the ASRock X99 Extreme3 by the Crucial website goes only up to DDR4-2666, while the one you bought is DDR4-3000.

The motherboard evidently can adapt itself, as it can manage to work with three RAM sticks, but not with four.

The usual suggestion in such a case is to up the voltage to 1.5v, as higher-powered RAM requires more voltage. However, the motherboard in question can only go up to 1.39, which I believe was not enough in this case, so this is not an option.

The only way to reduce the voltage required by the RAM is to reduce its frequency, which was apparently the solution taken by the workshop that made it work for you with four RAM sticks.

Your options then are either to work with four RAM sticks but with reduced speed, or stay with three RAM sticks working at the full speed of the motherboard (which is still below the true capacity of the RAM your bought).

  • Thanks for your input. My aim is definitely to use the 4 RAM sticks, first with any working configuration, on top of that ideally with the fastest. Setting DRAM voltage=1.39V causes DRAM frequency to be [DDR4-1600, DDR4-1333, DDR4-1066, DDR4-800]. The DRAM reference clock is 133Mhz or Auto. I tried all combinations without success. I didn't touch BCLK frequency (min 96, default 100, max 300). The label says it's for overclocking and I'm not sure which value to try without risking damage. Do you have any more suggestions? I'd be grateful. Mar 11, 2020 at 20:24
  • What you are asking for is called RAM underclocking and requires specialized knowledge. However, the BIOS may be able do the work for you if it supports XMP profiles. Read about it in the articles What are XMP profiles and how do I use them and also Extreme Memory Profile (XMP) - Intel. Use CPU-Z as explained in the above links.
    – harrymc
    Mar 11, 2020 at 20:37
  • Any advance with the problem?
    – harrymc
    Mar 14, 2020 at 21:32
  • I have no idea how to select the XMP profile in the UEFI. The links require a Windows OS. I don't have one. Mar 14, 2020 at 22:44
  • 1
    Now that you know more about the problem, you could ask the workshop what exactly they are doing and post an answer here, for future readers.
    – harrymc
    Mar 15, 2020 at 14:59

The first thing I would try is to reset everything (including voltages) to auto.

Second, higher voltage does not always yield better performance. Sometimes it will impede performance by causing higher heat production.

Start with the default voltage and if you aren't getting reliability at full speed try incrementing it a small amount of time. A utility such as MemTest86+ can help with this.

Don't worry about getting the full timings. Some processor motherboard combinations will never get your full optimized timings on timing optimized RAM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.