2

I know this is the n'th question out there on the "Error splicing file: Input/output error" message, but I'm experiencing some behavior inconsistent enough with the other posts I'm reading to merit posting.

Simple backstory:

I filled the microsd card in my phone so I got a larger one and wanted to copy all my old files over.

First sign of trouble:

I connect both of the microsd cards, run up nautilus, and do a simple copy of all the files, but after a few successful copies I get "Error while copying filename.jpg" ... "Error splicing file: Input/output error", and the volume I'm copying off of is unmounted. No more luck with bash, using cp gives cp: error reading 'filename.jpg': Input/output error and unmounts. To be doubly sure I tried in both Fedora and Ubuntu. I also tried copying the files from one microsd card to the other, from the microsd card to a local disk, and without a microsd adapter by putting the card in the phone and connecting the phone. Always the same problem. And I tried ddrescue once, still the same result.

What's different

So far this story sounds like dozens I've already read which invariably end with the disk having gone bad and just resorting to a backup. There are two discrepancies I can't get past in my case though. First, I've been using the microsd card daily in the phone without a single sign of trouble. I often go back to old photos on the card, and it isn't just a couple bad files, from what I can tell it seems to be about every 1 in 10 or 1 in 20 files that won't copy. I can't understand how a bad disk could explain why the files cannot copy, but I never noticed it on the phone. Second, and this is looser, but my impression had always been that flash memory doesn't go bad in the same way spinning disk drives do. I was surprised that the microsd card could have gone bad, but maybe I shouldn't have been.

So my question

is, what could be going on here? Does it sound like I'm just seeing this as unusual where more experienced minds might see it as more typical? Does it sound like parts of the microsd card have just gone bad? Could there be something else going on?

  • If the file system directory has gone bad anything is possible. – DavidPostill Aug 27 '18 at 8:25
  • Oh, and dd also failed in the same way. – fedora Aug 27 '18 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.