0

In Windows 10, Windows magnifier works with ctrl + alt+ mouse scroll.

But it doesnt works with the same keys in windows server 2012. Any idea to make it work as in windows 10?

As you can see below, on Windows 10:

enter image description here

EDIT:

This is the auto hotkey code that can be used to achieve ctrl+alt+MouseWheel on Windows Server but Since Win++++ is also the shortcut key to open Windows Magnifier, it opens up magnifiers inside Remote Sessions which makes it very laggy.

^!WheelUp::SendInput, #{NumpadAdd}
^!WheelDown::SendInput, #{NumpadSub}
  • I also try to use the magnifier both on the windows 10 and windows server 2012, and the keyboard shortcut ctrl +alt + mouse scroll didn't work on the windows server 2012, too. I think it could be not supported on the windows server 2012, or it is disable by default. – OOOO Aug 27 '18 at 7:42
1

The magnifier works fine for me on Windows Server 2012 R2 Essentials using the shortcut Win++.

You might be missing some system features. I have the following installed which might apply :

  • User Interfaces and Infrastructure
    • Graphical Management Tools and Infrastructure
    • Server Graphical Shell
  • 1
    Windows and +/- is working. But I want ctrl+alt+mouse_wheel. The way it works in Windows 10. – MYGz Aug 27 '18 at 9:43
  • You may map these using AutoHotkey. For some examples see post1 and post2. If still in doubt the persons on the AutoHotkey forums are pretty helpful. – harrymc Aug 27 '18 at 9:49
  • Thanks harry. This looks good. I'll come and update if I find a solution. – MYGz Aug 27 '18 at 9:55
  • got the auto hotkey hack. But unfortunately the windows magnifier shortcut hotkey is making life miserable. Code updated in question. – MYGz Aug 30 '18 at 11:45
0

With the help of Auto Hotkey as suggested by @harrymc I achieved the same windows 10 like hotkeys on Windows Server 2012.

^!WheelUp::SendInput, #{NumpadAdd}
^!WheelDown::SendInput, #{NumpadSub}

Though it works perfect on host system, it opens up magnifiers when zooming in on RDP client windows operating systems as well.

So I'm looking to disable Magnifier on Remote Machines.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.