0

I have been trying to copy photos and video files from my laptop to a flash drive. Every flash drive I've tried seems to corrupt the same said files.

I've tried three flash drives, all of differing file systems (exFAT, Fat32, NTFS), and brand quality. The thing is, it transferred all the files successfully to my external hard drive and they are able to be opened and viewed, both from the laptop and external hard drive.

I thought maybe I needed NTFS since that's my external and laptop file system. So I tried to format both of the low-end flash drives since the high-end brand is not mine. It went for almost 19 hours, only to end in saying it cannot format the drive.

I have read many different posts and have tried many things. These same files have given me the "might be corrupt" and "cannot copy with properties" errors. But, as I said, they are able to be viewed and opened from the laptop and external hard drive.

I haven't tried TeraCopy yet, but will try that next. Still, any help or advice or questions would be appreciated.

1

Using Occam's razor, I would guess that the files themselves are corrupted on the disk.

To check, run the chkdsk C: command (if the disk is C:). If it finds errors, then you have the problem that fixing these errors might destroy the files if you don't have any other valid backup.

You should first use a S.M.A.R.T. tool to verify the general health of the disk.
See for example this answer of mine to get you started.

If the disk comes up as healthy, you may attempt to repair it using chkdsk. See for example :
How to Fix Hard Drive Problems with Chkdsk in Windows 7, 8, and 10.


Notes :

  • Another system check is sfc /scannow.
  • Image repair tools are found here, most are commercial but have trials.
  • VLC can be used to repair video (link).
  • For repairing video, see these articles : article1, article2 and this tool. Other commercial services can be found by googling for "recover damaged videos".
  • OK so I downloaded speccy and ran it (free version) but everything came back saying is good. Haven't done the chkdsk because I don't want to corrupt anything I already have as u said might happen. – GIJOEY84 Aug 29 '18 at 4:29
  • OK so oddly enough I have been trying different methods from single file to entire folders. Some take time to copy and go fine then nothing in the flash drive. I even check the files after I transfer opens good first time but after that it seems to become corrupted or unviewable again. I downloaded terra copy tried it on one single photo I was having troubles with. It transfered and was viewable however I did not wait to retest later and just went ahead and am reformatting the drive again and will try bulk copy using terrace copy. – GIJOEY84 Aug 29 '18 at 4:44
  • Also my computer would not boot up proper for a long time and had to turn off and back on then off and so on til it finally came online. As I said speccy says everything is good to go. So maybe I have some sort of udetectable Trojan somehow downloaded corrupting files and sectors idk but I am at a loss for how this is happening. – GIJOEY84 Aug 29 '18 at 4:45
  • If you suspect a virus see this post. However, the best action in my opinion would be to format the disk and reinstall everything (slow format - not quick, that might fix magnetic degradation). – harrymc Aug 29 '18 at 5:57
  • OK so I used terracopy and it seems that it worked at first glance it was the same space taken up. This morning I place the flash drive in and boom folders are empty but same space being taken up none the less. I'm at a loss for what's going on here – GIJOEY84 Aug 29 '18 at 19:32
0

Since the files are view-able, I would open them with a program that edits pictures and then save them (one by one) to the flash drive. You might have to make a small change to a pixel in order to save a picture. It is also possible that you will get an error message when you open one of them in the editing program which can give you a clue as to what the problem is with them. Whatever it is, the copy is misinterpreting something about the files.

  • So I tried this many ways and it seems that the new file gets corrupted immediately following a screenshot of it or an edit. It seems to be spreading the infection of corruption across other files now too if it is the files. – GIJOEY84 Aug 29 '18 at 4:15
  • Do you have the problem if you save to a different folder on the hard drive? I mean, could the problem be with the flash drive? – ZuberFowler Aug 29 '18 at 5:59
  • I tried the saving to a new spot on the hard drive but it still would.give the same problems. I just got done copying using terracopy so hopefully worked about to test them. – GIJOEY84 Aug 29 '18 at 6:51

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.