0

Problem: I have files that have been output by WinEdt whose icons have accidentally been changed. How can I get them back to normal?

Files

The image with the "corrected" .synctex file icon:

Files with Corrected Icon

Background: I recently installed a new hard drive and ended up just copying a lot of files over (it wasn't the primary hard drive but it did have WinEdt installed on it). As a result, my WinEdt application was moved over and I ended up having to select a default application to open certain files. This caused Windows to associate the wrong icon for these types of files. I'm just wondering how to undo this... In the photo above, the .tex file type has the correct symbol while the .synctex and .out files have the wrong symbol.

I managed to find another question that seemed similar, and I ended up deleting something in the Registry Editor that brought the .synctex filetype's icon back to normal, but the same process didn't work for the .out extension.

  • Could you show the file names with their extensions? (Explorer, View, Options, View, uncheck "Hide extensions for known file types", OK) – harrymc Aug 28 '18 at 16:48
  • @harrymc: I've included a picture with the file extensions. – Clayton Aug 28 '18 at 17:01
  • You may use the free application FileTypesMan to examine the properties of the bad extensions and change them. You may report here what's wrong. – harrymc Aug 28 '18 at 17:41
1

I recommend that you reinstall WinEdt and use WinEdt as the default program for those files.

If this still doesn’t work, you can open the WinEdt Configuration Wizard, and click on the File Types Associations tab, like this: enter image description here

Then you can associate those file types.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.