35

I have a chat page open at https://app.purechat.com/quick-links and after a few hours, I come back to the page and Chrome reloads it because it has killed it in the background. The app thinks that I am offline and I am not getting chat notifications. How can I stop Chrome from killing the tab it is loaded in? I have 32GB.

  • 8
    Chrome is not killing your tab, its hibernating it, to consume memory. See also: developers.google.com/web/updates/2015/09/tab-discarding – LPChip Aug 30 '18 at 21:12
  • 3
    @3D1T0R OK I pinned it. But then it moves it to the far left, while I normally keep my development environment on tab CTRL+1 and the chat in CTRL+4. – Chloe Aug 30 '18 at 21:14
  • 10
    @LPChip: According to that page Chrome is killing it: "What do we mean by discarding? ... We kill it but it's still visible on the Chrome tab strip." however it also points to a solution for @​Chloe: "A new page called chrome://discards lets you list what tabs are currently open and we try to share some insight into how interesting (we think) they are to you, from most to least." From that description it may not seem like a solution, but going to there in current versions of Chrome gives me a list of tabs it might discard, and offers a "toggle" option to prevent discarding certain tabs. – 3D1T0R Aug 30 '18 at 21:23
  • 17
    @3D1T0R Isn't it obvious that 32GB refers to RAM? The asker is surely saying, "I have plenty of RAM so Chrome doesn't need to junk this tab to save memory." 32GB of disc space would be pretty much irrelevant. – David Richerby Aug 30 '18 at 23:05
  • 6
    @DavidRicherby: Yes & No. It's obvious to someone who knows computers inside and out that that's what it should be referring to, but those of us answering questions on SE sites don't necessarily know how much experience with computers an asker has, and there's a chance (for all I know) that @​Chloe is using a netbook with a 32GB SSD and is saying "I have 32GB." because they bought "the 32GB model" of that particular netbook & didn't realize that it has very little RAM. (Note: I'm not saying that's the case, but without clarification from the OP, we don't actually know.) – 3D1T0R Aug 30 '18 at 23:35
55

Alternative 1

To stop Chrome from reloading pages when you return to them after they have been in the background:

  1. Enter the following into your Chrome address bar: chrome://flags/
  2. Search for the "Automatic tab discarding" flag
  3. Set it to "Disabled"

You may also want to set the "Offline Auto-Reload Mode" flag to "Disabled".


Alternative 2

If you don't want to disable Automatic tab discarding for all the tabs, alternatively, you also have the option to discard select tabs manually via chrome://discards.

On that page, if you have automatic tab discarding still enabled, you can click "Toggle" next to any tab to prevent it from being discarded automatically.


Alternative 3

Pinning the tab will also prevent it from being automatically discarded, however, the pinned tab is moved to the far left which may be unacceptable behavior (particularly for those who use keyboard shortcuts to navigate through their first few tabs). Pinned tabs are also smaller than regular tabs.


References:

https://developers.google.com/web/updates/2015/09/tab-discarding
https://www.guidingtech.com/stop-chrome-reloading-tabs-automatically-switching/
https://www.makeuseof.com/tag/10-hidden-chrome-settings-changing/

  • 3
    Can you add the bit about chrome://discards and the Auto Discardable Toggle link? No one wants to disable the feature for all the tabs. – Chloe Aug 30 '18 at 22:16
  • 1
    Regarding Option 1, I do not have that chrome flag on my chrome://flags page. Any idea why? I am on Chrome 68. – Gaurang Tandon Aug 31 '18 at 3:37
  • Regarding the third option, do Ctrl+1 etc. work for switching to pinned tabs? – deltab Aug 31 '18 at 5:53
  • Does Chrome also discard "tabs" that are opened in a custom window (as done with Menu > More tools > Create shortcut... > Check "Open as Window"? It would explain why Discord is not creating any notifications anymore for me after having that window minimized for some time. – Ray Koopa Aug 31 '18 at 8:08
  • 1
    Alternative 2 is not working. It still discards my tabs and reloads them when I come back, even though I turned the toggle off for that tab. – Chloe Sep 6 '18 at 17:22
6

I was able to go to chrome://discards/ from the link in the comments and toggle a setting on the tab to prevent it from being killed.

enter image description here

  • 6
    Does this persist after exiting and reopening Chrome? or do you have to toggle it each time you launch Chrome? – 3D1T0R Aug 30 '18 at 22:19
  • 1
    @3D1T0R On my version of chrome (68.0.3440.106 - 64-bit) across a relaunch (from the flags page's "Relaunch" button) the toggle did not stay disabled – Taelsin Aug 31 '18 at 14:27
  • Then you may be better off just pinning the tab, as that persists to the next time you launch Chrome (as long as you don't close the window it's pinned in prior to exiting Chrome, e.g. close that window last, or use Menu > Exit or Ctrl+Shift+Q to quit). – 3D1T0R Aug 31 '18 at 16:34
  • This doesn't actually work. Even when toggled off, it still discards the tab. – Chloe Sep 6 '18 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.