8

When using Microsoft Edge in Windows 10 (v1803), if I click on a Web link to a PDF file, like this one, Edge opens the PDF in a tab using its internal PDF viewer.

How do I configure Edge to open the PDF in my default external PDF viewer instead (e.g. Sumatra PDF or Acrobat Reader)?

I stress that I am not asking how to set my PDF viewer (Sumatra PDF) as the default PDF viewer! (This was discussed e.g. here)

In fact, Sumatra PDF is already the default PDF viewer in Windows 10, and PDF files properly open with Sumatra PDF when I click on a file in Files Explorer. However, the files still open in a tab of Edge when I click on a web link to a PDF (like the above one) file within Edge.

To further clarify, what I am looking for is something equivalent to the Google Chrome Setting "Download PDF files instead of automatically opening them in Chrome." This was addressed in this question and I am looking for the equivalent with Edge.

I suggest testing your answer with this PDF link, to make sure the PDF does not open in Edge, before posting.

FYI, this same question was asked in the Microsoft Community here, but it was misinterpreted and has no useful answer. Moreover, that site is dominated by noise. So I am hoping the more reliable Superuser community will have a better and more up-to-date answer.

4 Answers 4

0

In the new edge, check the following:

Settings in Edge

3
  • 2
    Please don't add signatures to your posts, especially ones containing links back to your own content. The Stack Exchange network is all about content—it's not a traditional discussion forum. Feel free to add any information you'd normally have in your signature to your profile. If people like your content, they might click through to find out more about you.
    – Ryan M
    Jul 13, 2020 at 2:23
  • Please explain your answer in sentences. Jul 13, 2020 at 9:14
  • Above comments aside, this should get upvotes, because IT WORKS! This is in the Edge browser "Settings" menu. Thanks!
    – Duncan
    Aug 14, 2020 at 16:56
6

I cannot believe your question has no upvotes and more people haven't asked this question. As you discovered, there are plenty of examples of people running into this issue, but they are always met with this same "Default Apps" non-answer.

So finally, here is the bug report and official response on this from Microsoft:

Hello,

I checked the design and determined that PDF web links will always open in the browser regardless of the default app association. The default association only works for local files.

Best Wishes, The MS Edge Team

Harry is right that there is no solution other than to move to another browser, since the complaint part has already been tried without any results. That is only wise, considering that Edge itself has decided to move to another browser.

1
  • Finally, the MS Edge Dev Channel microsoftedgeinsider.com launched today has a new option "Download PDF files instead of automatically opening them"
    – divenex
    Apr 8, 2019 at 19:11
3

Find it, & solved.

go on Setting/Parameter menu. Then Web Site Autorisation Then go to PDF entry Choose Always open external solution for PDF.

2
  • Wow, this should get more upvotes! You still need to click the downloaded file to open it, but works more or less like I wanted it to! Been looking for ages
    – David Cian
    Jun 7, 2020 at 19:38
  • Seems like maybe there's a solution here... but we need more detail. Which "Setting/Parameter menu"? The one in Edge? Or Windows? I don't see any "Web Site Autorization" in either.
    – Duncan
    Aug 14, 2020 at 16:54
0

On the new Edge (with ocean colors icon) go to the top right three dots menu, Cookies and site permissions, PDF Documents, All permissions, and select "Always download PDF files".

PDF files will now auto-download but still need to be opened manually.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .