1

My Windows 10 machine would sometimes automatically boots up at night for no apparent reason. Is there some sort of log that I can check that would give an explanation?

  • 1
    that's because of the BIOS and not Windows. In BIOS setup you can see the option to start the PC after power failure and the alarm timer to automatically start the PC at some point of time – phuclv Aug 31 '18 at 16:44
  • You could check my answer here: superuser.com/a/1350900/926024 to get the exact time of the boot. If it's always the same time there might be some script, BIOS or WOL feature that triggers the startup at a specific time. Other answers in the question I've linked might also show you more details about how the start-up happened. – confetti Aug 31 '18 at 16:45
  • 1
    Do you use Shut Down, or sleep (or hibernate) ? Is this a laptop, and do you close the lid when you're done with it? Windows the OS can come up from sleep but not from full shutdown. As others have mentioned, if it's fully shut down, then the BIOS is waking it up, usually from LAN or BIOS schedule. – Christopher Hostage Aug 31 '18 at 17:26
1

To prevent windows 10 from automatic wake up one need to disable wake up timers in:

Control Panel\All Control Panel Items\Power Options -> Change plan settings

enter image description here

1
  1. Report information about the last event that woke the computer: powercfg /lastwake
  2. Lists devices that are user-configurable to wake the system from a sleep state: POWERCFG /DEVICEQUERY wake_programmable
  3. Lists devices that are currently configured to wake the system from any sleep state: POWERCFG /DEVICEQUERY wake_armed
  4. Returns all devices that support waking the system from any sleep state: POWERCFG /DEVICEQUERY wake_from_any

After finding culprit maybe you can remove the SW or HW. If not reference @Alex's answer to disable wake timers in power settings GUI

Links: https://docs.microsoft.com/en-us/windows-hardware/design/device-experiences/powercfg-command-line-options https://msdn.microsoft.com/en-us/library/dn898599(v=vs.85).aspx https://ss64.com/nt/powercfg.html

0

One of the multiple reasons could be the Wake-On-LAN feature.

Is there any mechanism in your network that would send out Wake-On-LAN packages? Also is your computer configured to respond to such packets?

  • 4
    Confirmation of this is easy; disconnect your LAN before you turn in for the night. No LAN, no signal can be received from the LAN to wake the PC. – K7AAY Aug 31 '18 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.