0

I have a DENON AV-Amplifier/Home Theatre system with HDMI passtrough (several HDMI inputs, one HDMI output to TV), connected to 5.1 passive speakers.

I purchased it more than 10 years ago, so it's not really up-to-date as far as Dolby Atmos and similar technologies are concerned, but it does support Dolby Digital TrueHD and DTS 5.1: I've been using them for several years with a Blu-Ray Disc player, a PlayStation 3/4 console and several STBs. I recently switched over to a desktop PC and a Raspberry Pi for gaming, YouTube, music and video playback.

I connected both devices via HDMI and set up 5.1 surround sound on both Windows 10 and OSMC (Kodi) and it seems to be working correctly: the display on my AMP/receiver says MULTI CH IN and lets me play 5.1 content with all speakers functioning as expected.

Now, what I found strange is that, unlike with my other "commercial" systems (e.g. gaming consoles, Set-Top-Boxes and my BD/DVD/CD player), the receiver is not detecting any Dolby/DTS signal coming in, and instead just generic "Multi Channel Input".

It doesn't look like what I'm getting is PCM as I'm able to set audio bitrate at the maximum value under Windows (at 24 bit), so I believe what's being used is just 5.1 bitstream. Is this protocol inferior (i.e. am I getting worse audio quality) compared to DTS/Dolby Digital, or are these different lossy protocols, or mere marketing?

Something I found rather interesting is that if I install the UWP "Dolby Atmos" app from Microsoft Store, and enable spatial sound mode "Atmos for Home Theatre" it will play the demo videos inside the app as "Dolby TrueHD" just fine, but then all the rest of the programs on Windows will be completely silent (any other audio refuses to play), most likely because my HT doesn't really support Dolby Atmos.
Of course on Linux there is no such software and so I wasn't able to test the Atmos app with my OSMC Raspberry Pi.

  • If you want to pass the original DD/DTS stream to your receiver, you need to enable audio passthrough in your player software. – Daniel B Sep 1 '18 at 14:51
  • @DanielB in Kodi's case it's quite obvious how to, but how would I do it - say - on Windows, with the Netflix app? – Manchineel Sep 3 '18 at 14:29
  • You basically use Google and find out. Some say “Dolby Digital” needs to be checked on your output device’s “Supported Formats” properties, but that information is detected automatically with HDMI. It may just not work at all. I don’t use Netflix, so I cannot verify. – Daniel B Sep 4 '18 at 8:06
1

The receiver is not detecting any Dolby/DTS signal coming in, and instead just generic "Multi Channel Input"

That is normal - the PC / Pi are rendering raw audio to a raw PCM bitstream, and passing this to the downstream device (e.g: AVR / TV).

If you were to play media (e.g: Blu-ray) that has a 5.1 DTS audio stream, then you'll find one of two things:

  • The PC decodes the DTS and renders this to the raw 6-channels (5.1) as PCM
  • The PC changes the audio stream presented to the downstream device to whatever the media provides and just passes the data straight through

Is this protocol inferior (i.e. am I getting worse audio quality) compared to DTS/Dolby Digital, or are these different lossy protocols, or mere marketing?

It's not a protocol, but rather an encoded audio stream - the audio is encoded in a certain way, possibly with compression, etc... The difference is where the decode is occuring - is the audio being rendered to its raw form (PCM) in the PC, or the AVR.

audio path

There may be some restrictions placed on transmitting PCM audio from a DTS source that has Digital Rights Management... but I'm not sure.

If your source is something like AAC, then decoding on the PC and transmitting PCM is the optimal solution - you don't want to decode AAC, encode to DTS, transport DTS and then decode DTS - it's unnecessary and can result in nasty artefacts due to the "DTS after AAC" layering.

... rest of the programs on Windows will be completely silent (any other audio refuses to play), most likely because my HT doesn't really support Dolby Atmos

As you surmised, this will likely be because your PC doesn't decode the Atmos stream, and the AVR can't decode it. The result is as you indicated - silence.

Because of the way Atmos works, there is a load of processing that needs to be done - individual sounds are stored as objects that have a position in 3D space, this allows the audio to be played in the best way possible according to your physical setup - room, speaker count, etc...

There may be a way to decode and render an Atmos stream on a PC, but I don't know of any...


There appears to be a "Dolby Access" app in the Windows store, but this appears to be more of a trial for use with headphones (2-channel).

Download this app to enable your free trial of Dolby Atmos for Headphones, or set up Dolby Atmos for home theater. Hear stunning detail, precision, and realism in your games and films, with sound that flows all around you — including from above and behind.

  • Thanks for the answer. Yes, the Dolby Access app is exactly what I tried. It has both an In-App-Purchase for "Atmos for Headphones" and a free "Atmos for Home Theatre" (the one I tried). Again, since my AVR cannot decode Atmos and only supports a basic 5.1/7.1 surround setup, it's not useful in any way. The built-in videos for demoing the app are most likely not in Atmos format. – Manchineel Sep 1 '18 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.