1

Computer: HP ProDesk 600 G1 DM (mini desktop). Windows 7-64 SP1

4 USB2 in the back and 2 USB3 in the front. I bought two 4-port USB3 hubs that have their own power supplies. When I connect the hubs to the back USB2 ports everything seems to work fine - devices plugged into the hub (each port has its own power button) always stay connected to the computer.

If I move the hubs to the front USB3 ports it seems whatever is connected to the hubs keeps falling asleep. When I say falls asleep, what appears is happening is the computer still sees the devices connected to the hub but the computer can't communicate with the device.

This is most prevalent with a few test phones I have connected to the hub - as I compile new app code and deploy it to the phones the Android adb just loses communication with the devices. I have to manually disconnect each phone and re-connect to the usb cable. When I unplug, the computer makes that "disconnected" tone and when I reconnect it makes the "connected" tone and everything works again. But 10 minutes later it all happens again. Its quite annoying.

For now I am reconnecting the hub back to the USB2 ports. But this "falling asleep" issue, if I recall correctly, seems to have been going on for sometime as I used to have 1TB external SATA drives connected to each USB3 port - and I would notice from time to time the drives were showing disconnected or it was connected but the drive couldn't be accessed until I disco'd and reconnected again.

I have checked power settings and disabled USB selective suspend and also verified that all power settings are disabled in Device Manager. Aside from thinking these USB3 ports are bad - I can't think of what else to look at or check.

update:

Two 2TB seagate HDD USB3 drives: Win7-64 desktop: do not work on any usb2 or usb3 port, do not work on hub. However, these drives did work at one point as they were routinely backing up my desktop Win10 laptop: drives work just fine on USB2 and USB3 ports

Two USB3 Powered HUBS: Win7-64 desktop: works on both USB2 and USB3 ports, problems with devices being randomly being disconnected Win10 laptop: works just fine on both USB2 and USB3 ports.

Other devices: Test Phones (2 diff Samsung, 1 Motorolla): all work connected to USB2 and USB3 ports, as well as work via the USB3 Hubs - however disconnects keep happening when USB hub is connected to USB3 port.

This is frustrating....beginning to think its a power problem with both USB3 ports on the desktop....but then the HDDs are not working connected to the USB2 (but that makes sense because the USB2 might not be sending enough power to the HDD). However, I plugged the HDD into the powered Hub that was connected to a USB2 and the HDD still did not work/get recognized.

I am baffled.

  • Do you see the same symptoms if you connect a 'phone direct to a USB3 port, rather than through the hub? – AFH Sep 1 '18 at 12:13
  • Try to disable USB selective suspend setting in Control Panel\USB setting. Also update USB3 driver from your motherboard's manufacturer. Is external hub has its own power supply? It could also happened if you hooked too many devices but each USB port on motherboard can provide only 500ma per port – Alex Sep 1 '18 at 12:17
  • @AFH -doing more testing. Phones through USB Hub work but get disconnected. Phones direct to USB3 works. However, 2TB USB3 hard drive connects to both hub and direct to usb3 port - does not work. Plug hard drive into usb2 and it works. – rolinger Sep 1 '18 at 14:20
  • @Alex - yeah, I noticed Samsung USB drivers failing via Windows update - going to try via HP now. USB selective suspend was enabled previously until I started troubleshooting this today - it is now disabled. the Hubs have their own power supplies, and each usb port on the hub has its own power button (all on). – rolinger Sep 1 '18 at 14:22
  • 1
    Right click on that device, go to properties and switch to details tab, switch there Property in dropdown to hardware IDs there would a string like USB\VID_XXXX&PID_XXXX&REV_XXX, right click on that, copy and put this string on google to decode device – Alex Sep 1 '18 at 16:05
1

Resolved:

USB3 continuously disconnecting USB2 and lower devices, while not working at all for USB3 devices.

Device Manager showing unknown device. Properties -> Details -> Hardware IDs revealed it was the PCI\VEN_8086&DEV_8C31&SUBSYS_21D0103C - quick google search returned that hardware id belongs to my computer (HP 600 G1 DM): Intel(R) USB 3.0 eXtensible Host Controller drivers / Hewlett-Packard HP ProDesk 600 G1 DM (M9Q80US#ABA).

I then went to HP Support to find the driver for the USB 3.0 eXtensible Host Controller, downloaded (sp72828.exe) and installed and it failed with error: Not compatible with this computer...I then tried the compatibility mode and it failed again with: wrong operation system. I then went directly to Intel site and grabbed the driver from there but pretty much got the same error messages.

I uninstalled the unknown host from Device Manager and tried again, got all the same error messages. Last ditch attempt, in properties of 'unknown device' i tried to update the driver, and manually pointed it to the directory that had the HP downloaded driver (sp72828.exe) and miraculously it installed correctly. All my USB3 connected devices came back, USB3 external hubs were working again. It appears to be an older driver (2015) and new ones show dates of mid 2017 - but I am going to leave it for now. Took me like 6 hours just to get it working again, not going to monkey around with it anytime soon.

Writing this out in case anyone else has the same issue, maybe this will help them resolve their problem.

  • This is the reason you should always install drivers directly from the vendor when possible. Would be interesting to know the date on the previous driver and the new driver. – Ramhound Sep 2 '18 at 3:31
  • This ordeal is a living proof that the Microsoft install/registry process is still a "spaghetti code", and if you are not a huge OEM and not on Microsoft support, any successful installation of the OS from official distribution installer on older hardware is nothing but a miracle. – Ale..chenski Sep 4 '18 at 20:43
0

As I see from the problem description, the major problem was the difference in USB 3.0 behavior between rear ports and front ports.

There is one serious difference between rear and front ports: rear ports have all traces on-board PCB, while the front have all similar traces PLUS extra connector PLUS extra cable. To get similar signal quality on longer channels, the corresponding host port PHYs must be configured for higher level of de-emphasis and stronger equalization on receiver side, to make the channels reliable. As I recall from the past, some OEM vendors would install two DIFFERENT USB host drivers for rear and front ports. To make it so, there must be exact knowledge of board USB configuration (which external port is connected to which internal pins) and have a custom driver. So installing generic driver might work, but leave the front ports somewhat deficient.

More, the HP ProDesk 600 G1 uses a 5-years-old Q85 chipset, ~2013, when the xHCI was rather buggy. One common method to fix hardware deficiencies was to use so-called "filter drivers" with Microsoft approval and assistance. As hardware progresses and hardware fixes implemented, newer drivers don't have these fixes, they expire. So the latest drivers are not necessary the best one for older hardware, and there could be functional glitches even if the system reports installation success. So the 2015 driver might be the best you can have.

That's is likely the reason why USB system frequently breaks apart with new system update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.