1

I have a Dell TB15 connected to two 1920x1080 screens (one via display port, other via HDMI; DP chaining always made trouble) and been using it with an XPS13 9360 running Ubuntu, and a Dell mobile workstation running Windows 7. Some firmare and driver updates needed but then it worked like a charm.

Now I have a MBP... A1708 Mid 2017 running MacOS X 10.13.6, and it does not work at all. When I plug in the TB15 on one of the two TB3 ports the LED on the plug stays off. But the funny thing: the Mac gets charged from the TB15 dock via thunderbolt. So I guess it must be a firmware / driver issue.

enter image description here

What I have tried:

  • checking if the two TB ports on the mac make a difference. no.

  • installing all OS updates offered. no.

  • checking if the dock gets shown in System information -> thunderbolt (see screenshot). "No device connected" on both ports.

  • installing the Thunderbolt3Unblocker kernel module that allows for using hardware unsupported by Apple from [1] see also [2]. A...

    kextstat | grep ryan

... in the console after a reboot shows it, so I assume it is loaded. I did expect too much, as I read that it only unblocks devices that show up in system information with a remark "unsupported"; but worth a try. However, nothing.

  • resetted SMC, NVRAM; see [3]. On reboot after command-option-p-r it asked me for a wifi key during boot, did something then booted up. But also did not solve the problem.

Now I am stuck. I really do not want to buy another dock as the setup has been working for me well; but I have to get the mac to work in my environment...

Any ideas appreciated.

[1] https://github.com/rgov/Thunderbolt3Unblocker

[2] https://9to5mac.com/2016/11/21/tb3-enabler-enable-unsupported-thunderbolt-3-devices-hack-macbook-pro/

[3] https://fedotov.co/apple-thunderbolt-not-working/

  • Thx for all your answers. I cannot really check if one of them works because I bought a Belkin Thubderbolt 3Express Dock HD which does what Iwant (except charging the Dell). If someone tells me he had the same problem and validated a solution I will accept the answer. – Marcel Boldt Jun 10 '19 at 9:34
1

Good afternoon,

Please follow this manual process carefully. It worked for me but i'm yet to get the display(s) working, but you may have more luck using the other display outputs on the dock.

I can confirm all of the USBs work, the 3.5mm audio works and my MBP 15" is receiving power

• You first need to reboot your Mac and hold cmd+r to get into the restore mode. Add the top go into the terminal and type csrutils disable, check this has been done by typing csrutils status.

• Restart and go back into your Mac normally.

• You now need a HEX editor, i've used iHEX from the Mac store.

• Shift+cmd+g and type /system/Library/Extensions

• Right click and show package contents

• Contents/MacOS and copy this to make a backup somewhere and copy it onto your desktop.

• Drag the IOThunderboltFamily from your desktop into iHEX

• Hit cmd+f

• Find 55 48 89 E5 41 57 41 56 41 55 41 54 53 48 81 EC 28 01, replace with 55 48 89 E5 31 C0 5D C3 41 55 41 54 53 48 81 EC 28 01 and hit cmd+s.

• Drag the file from your desktop into Contents/MacOS and when asked to overwrite click yes.

• Downlaod KextUtility (http://cvad-mac.narod.ru/index/0-4) and run it and let it do it’s magic.

• Restart your computer and plug the dock in.

Hope that helps, learnt all of it from the wonderfully helpful egpu.io.

  • Thx for your reply Tom. In your answer you do not write which file to right-clock on and open package contents. I have been assuming that you refer to IOThunderboltFamily.kext. I did exactly follow your process but it did not change for me. Mac still gets charged but the dock does not show up in sysinfo. – Marcel Boldt Sep 1 '18 at 18:20
  • What is this procedure actually doing? – Marcel Boldt Sep 1 '18 at 18:25
  • Apple blocks TI82 thunderbolt controllers, this removes the block I believe. I'll try and clarify when I'm home with my Mac for you. – tomjyoutwit Sep 2 '18 at 13:28
  • So instead of supporting more hardware, they actively put effort into making it harder for folks to use their stuff with MacOS? x-D Thanks for your effort, Tom! Let me know if you need more details... – Marcel Boldt Sep 2 '18 at 14:06
  • But wouldn't the behaviour then be that the device shows up in System Information as " unsupported", like in this screenshot: cdn.egpu.io/wp-content/uploads/2017/05/… – Marcel Boldt Sep 2 '18 at 14:16
0

This is an issue with OS X.

OS X (versions 10.13.4 to 10.13.6) did not support DisplayPort drivers which are required by this docking station.

However, OS X 10.14 fixed this issue. If you can update to 10.14 you shouldn't have any problem with this.

  • That’s some interesting information! Do you perhaps have any reference on this (even if it’s your own experience)? – Daniel B Jan 11 '19 at 20:56
  • Mac running 10.14 and DisplayPort doesn't work connected to a TB15 – pmont Mar 20 '19 at 15:38
0

Thunderbolt3Unblocker is a relatively safe and easy way to add support for the Dell TB15 Thunderbolt dock.

Caveats: I used a Win10 laptop to update the TB15 firmware. Dell's update software presented the firmware update.

USB and Power Delivery work, but DisplayPort/HDMI outputs do not.

0

The Dell TB15 was recalled in 2016, however in many cases Dell left the TB15 in the hands of their respective owners and just gave them a TB16 and now these TB15 are abudant on eBay.

enter image description here

  • Well the problem afaik was just that the TB15 had a tendency to overheat in particular with two 4K screens. Therefore they put a fan into it and called it TB16. But that one makes constant noise... I do not have 4K screens and I wanted the silence. However I do not think there is a difference btw TB15/16 about drivers/firmware. – Marcel Boldt Jun 10 '19 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.