1

I'm Austrian - therefore I want my keyboard to be in German, all the time so I can write ü,ö,ä, etc. and not having z and y change places (QWERTZ-keyboard).

But I want all apps, and everything on my laptop to be in English. Until now everything worked well but about a week ago something changed. Maybe I'm pressing some keyboard shortcut all the time but the keyboard layout constantly changes to english. I tried changing it in the settings

"Settings >> Time & Language >> Region & Language >> Advanced Keyboard Settings >> Language Bar Options >> Advanced Key Settings >> Setting everything to None"

But that didn't work. Does anyone know how I can change my language to English on my Windows 10 Notebook but keep the keyboard layout for German all the time and disabling ALL keyboard-shortcuts which would change that keyboard layout again.

enter image description here enter image description here

  • Just remove the US keyboard (and keep the only the layout you're actually using). – GabrielaGarcia Sep 2 '18 at 21:35
  • @GabrielaGarcia where can I remove keyboards? I can only remove languages, which I don't want to. – Féileacán Sep 2 '18 at 21:44
  • Click the first Language listed - this is your system language - then Options and you'll see the keyboards. – GabrielaGarcia Sep 2 '18 at 21:49
  • @GabrielaGarcia mHm, that didn't work very well. I could change the keyboard language but still I have somewhere an UK keyboard, although my languge is the irish english? – Féileacán Sep 2 '18 at 22:10
  • 1
    The screenshots show everything is as I suggested. So, you're saying it changes to anther layout even if not present in settings? If that's the case I can only suggest rebooting after confirming the settings. If you notice the same behavior then maybe something else is wrong with yor Windows, it definitely shouldn't be toggling to a keyboard that isn't there. – GabrielaGarcia Sep 2 '18 at 22:32
1

According to your description, I test in my Windows 10 environment.

Way 1:

According to your screenshot, you may add German keyboard in Settings->Region & language-> Languages->English (United States)->Options:

enter image description here

Then we get the German keyboard as below, it is an English(United States)-based German keyboard:

enter image description here

Way 2:

I think we can try to add German keyboard in Settings->Region & language-> Languages->Add a language.

Then we get the German keyboard as below, it is an German(Austria)-based German keyboard:

enter image description here

I think keyboard-shortcuts in way 2 does not affect the keyboard layout, so we do not disable keyboard-shortcuts, we can also use switch the input method with the mouse. And keyboard-shortcuts in way 2 may affect the keyboard layout, because it is an English(United States)-based German keyboard.

We can try Way 2, hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.