0

I got this laptop a couple of years ago, and after a while I noticed that the wifi and bluetooth doesn't work on some boots. After some searching I found that other people have the same issue with this. The suggested "solution" was rebooting and hitting Fn+F3 (enable/disable WiFi) repeatedly on the BIOS boot screen. It might take a few reboots.

I am now pretty sick of this and am wondering if there's anything else I can do?

The device in question is a dual WiFi and Bluetooth device: Qualcomm Atheros QCA6174.

The issue is the same if I boot into Windows 10 or Ubuntu. The network device simply isn't detected. Hitting Fn+F3 in the OS does nothing. So it seems to be a hardware / BIOS issue.

I work mostly in Linux, and I didn't have to install any particular driver to get the networking to work initially, given that the device is detected.

So, is there anything that can be done? Is it possible to get the Fn+F3 command to work in the OS so it doesn't require a reboot?

Is it a firmware issue? Updating the BIOS a year ago didn't help. Would an opensource BIOS work?

Or can the device be cost-effectively replaced?

  • 1
    There are newer UEFI versions available (the manufacturer still uses "BIOS" incorrectly so you should look at the "BIOS/Firmware section of Drivers and Manuals.) – user931000 Sep 3 '18 at 2:38
  • @GabrielaGarcia the two updates I don't have only mention Spectre and SCCM, so I doubt it's a fix. – Sarke Sep 3 '18 at 3:07
  • You should update anyway. Spectre is serious. It may or may not solve the WiFi issue but if it doesn't nothing will. This is purely a UEFI bug. – user931000 Sep 3 '18 at 3:10
  • Updated, still an issue. – Sarke Sep 3 '18 at 3:24
0

I bought a Intel 9260NGW on aliexpress for $20. Now it works, and it's faster too.

I'm not sure if that completely rules out being a firmware issue, but at least it's hardware related. Replacing the hardware solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.