0

My Dell Vostro 2520 64-bit laptop. Shows the following error on power on.

Internal hard disk drive not found

To resolve this issue, try reseat the drive

No bootable devices -- strike F1 to retry boot, F2 enter setup menu, F5 enter PSA

I ran the F5 Dell internal diagnostic tool. It shows all the rest of the peripherals working correctly except no hard drive status.

The last thing I did with the laptop was to install Virtual Box and install Windows 7 32-bit OS in the virtual guest machine. The next day I got the hard disk not found error. So tried to repair any possible corrupt OS to boot from USB drive but on reboot I get a similar "No bootable devices" error.

The legacy option is enabled and secure boot is disabled in the BIOS.

To fix a possible configuration issue tried to boot from USB drive to repair os but again it shows no bootable device found error. Tried with different usb drives hp and sandisk, USB drives are recognized and shown in the bios but while booting it show no bootable devices

What could be the possible cause and fix for the problem.

  • 1
    The hard drive had failed and the bios no longer see's the device (not a windows problem), replace the drive and reinstall Windows. – Moab Sep 3 '18 at 19:54
  • Have you actually followed the error suggestion??? The laptop should have a small cover on the underside that can be unscrewed to reveal, typically, the hard disk and RAM bay to allow you to remove/upgrade those components. The very first thing I would try is to re-seat the hard disk as the connections may have oxidised and may now be preventing the flow of electricity to/from the hard diskm thus displaying the symptoms you have. – Kinnectus Sep 5 '18 at 11:36
0

Press F2 and check if the hard disk in the BIOS is detected. If HD is not detected, it seems that you have a physical error and maybe you need to replace your hard disk. If it´s present, then maybe it´s a configuration error that could be fixed reinstalling your boot entering your MS Windows DVD and instead of doing a new installation click on repair.

0

Tried to boot from USB drive to repair windows. For the first time the System Recovery Option window showed up but could not select c:/ drive to complete. The next option is to run commands from command prompt but when powered on the laptop that same 'The windows manager. The windows boot configuration data file does not contain a valid entry' screen is shown instead to boot from usb drive to show System Recovery Options. Tried all short F8, Shift + F10, nothing happened. Somewhere it is missing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.