3

I brought a computer with Ubuntu and I tried to install windows 10 from a usb (I do not know why it did not work from a USB, error while loading files) so I entered the bios and deselected safe boot but I accidentaly disabled legacy booting...and now I am stuck on this screen (how? keyboard not working)

Is there a solution without opening the case? don't want to lose my warranty since day 1

3
  • Why can't you boot into the BIOS?
    – harrymc
    Sep 4 '18 at 15:00
  • You should describe the screen you're seeing.
    – Daniel F
    Sep 4 '18 at 15:25
  • 1
    Since Windows does not know how to work with the ext4 filesystem, this result is likely unless you completely erase the PC's HDD or SSD. The installation of Windows 10 will almost certainly break the Ubuntu install, even if it is your intent to set up dual boot by repartitioning to add an NTFS partition for Windows. Please check your warranty terms and conditions to see if installing a different OS will void your warranty. Also, please click on edit above and to the left and advise the make and model of your PC, so we can better advise you.
    – K7AAY
    Sep 4 '18 at 15:43
1

and now I am stuck on this screen (what screen?? )

Normally, if you reboot without the USB stick, there is no reason you can't access the BIOS/Setup (F12, F8, F2, Del, et cetera). Once in the BIOS/Setup, you can change from the legacy boot to the UEFI boot which Windows wants.

or i don't understand...

PS: Excuse me, harrymc, I don't see your answers.

1

I had the same issue. The BIOS screen wasn't showing on startup but instead, my PC booted straight into GRUB. With the keyboard not being recognized. For all those having the same issue, I was able to get back into the BIOS by unplugging the startup drive from the motherboard.

Although this only worked, because I haven't had a warranty to care about.

0

This is helpful Excerpt:

At the grub prompt try these commands:

set pager=1
ls

Now, suppose the output of ls is: (hd0) (hd0,msdos2) (hd0,msdos1), in order to find the linux root filesystem run:

ls (hd0,1)/ which should give you all the files/folders in / such as bin/ boot/ cdrom/ dev/ etc/ home/  lib/ etc.

Once this is done continue with:

set root=(hd0,1)
linux /boot/vmlinuz-3.13.0-29-generic root=/dev/sda1
initrd /boot/initrd.img-3.13.0-29-generic
boot

Of course replace vmlinuz-3.13.0-29-generic and initrd.img-3.13.0-29-generic with what you find in your /boot

/dev/sda1 is the location of the root system. You may have to change it if /dev/sda1 did not work.

OR ALSO:

Run those commands

grub> linux  (hd0,1)/vmlinuz root=/dev/sda1
grub> initrd  (hd0,1)/initrd.img
grub> boot

Replace hd0 with your hdd number and /dev/sda1 with your partition holding the /boot mainly the dafult will work if you don't have more than one hdd and with default installtion

 When you can boot again you shoulf fix your problem

 sudo update-grub

Here is another one => repair-grub2-when-ubuntu-wont-boot/

And here => repair-and-reinstall-grub-boot-loader-in-ubuntu/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.