6

I have a MSI laptop with an external USB keyboard and a mouse connected to it. This device controller, "Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)", wakes up my PC from sleep. I have installed the latest driver for that and I have tried several methods to solve this but to no avail, including:

  • check Task scheduler for any task that wakes my PC from sleep
  • update USB drivers to their latest version including that Intel USB controller, although, Intel's driver for this device is fairly old and the driver from Microsoft for this device supersedes the Intel's one.
  • disable "wake timers"
  • disable "hybrid sleep"
  • disable Windows 10 "automatic maintenance" feature.
  • Use troubleshoot in Windows-10 to troubleshoot power

I ran the following command once my PC is spontaneously waked up from sleep:

C:\Users\farid>powercfg /lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 1
  Wake Source [0]
    Type: Device
    Instance Path: PCI\VEN_8086&DEV_A12F&SUBSYS_11C81462&REV_31\3&11583659&0&A0
    Friendly Name: Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)
    Description: USB xHCI Compliant Host Controller
    Manufacturer: Generic USB xHCI Host Controller

I also ran the following commands to solve this but I have not checked whether my PC is waked up again or not. However, if it doesn't wake up anymore, I don't want to disable wake up from my external USB devices because the lid of my laptop is closed and I use to wake my PC from my external mouse or keyboard.

PS C:\WINDOWS\system32> powercfg /DEVICEQUERY wake_armed
HID Keyboard Device
HID Keyboard Device (001)
HID-compliant mouse (003)
PS C:\WINDOWS\system32> powercfg /DEVICEDISABLEWAKE "HID Keyboard Device"
PS C:\WINDOWS\system32> powercfg /DEVICEDISABLEWAKE "HID Keyboard Device (001)"
PS C:\WINDOWS\system32> powercfg /DEVICEDISABLEWAKE "HID-compliant mouse (003)"

My connected devices to this controller are as in the following image:

enter image description here

10
  • 1
    What devices do you have connected to that controller?
    – Ramhound
    Sep 5, 2018 at 2:51
  • How do I know? I think a mouse and a keyboard! Sep 5, 2018 at 3:12
  • You may need to disable wake up from USB from UEFI/BIOS.
    – user931000
    Sep 5, 2018 at 9:32
  • Look at device manager, we need facts, “I think” isn’t going to get this problem solved
    – Ramhound
    Sep 5, 2018 at 11:53
  • 1
    Same Problem here with my Razer Blade Laptop. The Bluetooth connected Logitech MX Master reactivates the laptop from sleep. No Energy tab at the BT Mouse Device in Device Manager. Tried /DEVICEDISABLEWAKE for all devices without success. No wake setting in BIOS.
    – Sinky
    Jan 1, 2020 at 15:29

1 Answer 1

1

I've had this same problem for a couple of years and I just now seem to have fixed it.

Even though it is reporting that it is the USB controller that is waking up the machine, I became pretty certain it was the network connection after much trouble-shooting, the machine finally slept through the night when I experimentally removed the network cable.

I normally have Wake-on-LAN enabled so that I can turn on my machine if I need to access it remotely, which in my limited experience, only ever responded to a specially formed "Magic Packet" specifically designed to wake up a machine with a specific MAC address.

But when I checked the "Advanced" properties of my network device in "Device Manager", I saw that "Wake On Pattern Match" was also enabled. That is far more permissive and seems to wake up if any other device on the network so much as mentions it.

So, I've disabled that, leaving "Wake On Magic Packet" enabled (which I can trigger via my router) and now my machine is happily able to sleep through the night even with the network cable connected!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .