1

I have recently bought a SATA 2.5 hard disk enclosure to externally connect my old Laptop SATA hard disk drive. The old hard disk drive is SATA II.

On the hard disk drive external enclosure that I have bought, there's mention of USB 3.0 and the USB cable and plug also looks like USB 3.0 type. It's a single cable with blue color inside the plug.

What I am trying to understand is would a SATA II hard disk drive, enclosed in USB 3.0 enclosure actually operate at USB 3.0 speeds?

After connecting the HDD, when I run USB Device Tree Viewer v3.2.1 it shows me H against the HDD device connected to USB 3.0 port. (Not to be confused with H: which coincides with drive letter, rather the superscript H on the left) See the screenshot. H means it's operating at USB 2 speeds.

Is there any way for me to confirm if the USB 3.0 enclosure is indeed USB 3.0 capable or it's still just USB 2.0?

I ran CrystalDiskMark on the same disk, once enclosed in USB 3.0 enclosure and another time in USB 2.0 enclosure and there's no difference in the speed whatsoever.

When I connect my USB 3.0 flash drive to the USB 3.0 port I get an S against the port in the app.

How do I confirm that the USB 3.0 hard disk drive enclosure is indeed USB 3.0 capable?

enter image description here

  • What speeds did you see? – Attie Sep 5 '18 at 13:17
  • 1
    Update your question to include the make and model number of the enclosure. Have you tried a different USB cable, you know for a fact, is a USB 3.0 cable? How long is the USB cable you are currently using? The potential bandwisth of a USB 3.0 exceeds that have a SATA II HDD. You will never exceed USB 2.0 speeds, if the device is not recognized, as a USB 3.0 device. The device currently is being identified as a USB 2.0 device, so either the enclosure is not actually a USB 3.0 device, or something else is going on. – Ramhound Sep 5 '18 at 13:37
  • Are these enclosures self-powered (have an external AC-DC adapter), or bus-powered (get their power from host port over the USB cable)? – Ale..chenski Sep 5 '18 at 20:41
3

Fundamentally, a hard disk connected using USB 3.0 will out-perform a hard disk using USB 2.0...

But it won't reach the 5Gb/s spec of USB 3.0.


USB 3.0 brings more to the table than just speed - it is much more efficient than USB 2.0 at transferring large amounts of data.

While USB 2.0 relies on "bulk transfers", USB 3.0 introduces USB Attached SCSI (or UASP), which improves throughput and reduces overhead even further - see this blog post by Startech (graphs below).

You'd be lucky to see much above ~45MB/s from a USB 2.0 attached hard disk.

As the graphs show, the throughput for standard "Bulk-only Transfer" (BOT, not UASP) over USB 3.0 exceeds the capability of a standard spinning hard disk (~110MB/s), so if you're hoping for more, then you'd better look into a capable SSD.

throughput

cpu usage


If the enclosure is only enumerating as a "High Speed" device (USB 2.0 / 480 Mb/s), then there could be an issue with the cable or the device itself.

  • Thanks @Attie. Does it mean that a USB 3.0 HDD Enclosure should report itself as 'S' in USB Device Tree Viewer app, even if it may be holding a SATA II HDD that's in itself going to operate at low speeds? The 'H' as seen therein is bothering me. I thought it should have been 'S' as long as the enclosure meets USB 3.0 specs. – rajeev Sep 5 '18 at 16:34
  • "Does it mean that a USB 3.0 HDD Enclosure should report itself as 'S' in USB Device Tree Viewer app" - I would expect so, yes. Check your cable, etc... – Attie Sep 5 '18 at 17:50
  • "even if it may be holding a SATA II HDD" - SATA and USB versions have nothing to do with each other... SATA II is 3 Gb/s which is A) faster than a spinning disk, and B) faster than USB 2.0 – Attie Sep 5 '18 at 17:51
  • I think I have found the culprit. For convenience I was using USB 3 extension cable and was plugging in the USB 3 enclosure into it. Now that I plugged it directly into the USB 3 back panel I am getting Super Speed rather than High Speed. The USB 3 extension cable worked well for lighter devices like USB 3 pen drives but it seems it does not sustain relatively power hungry devices like HDDs in enclosures and somehow falls back to High Speed. This also confirmed that the USB 3.0 enclosure that I have bought is indeed USB 3 Super Speed capable. – rajeev Sep 5 '18 at 19:03
  • extensions don't usually play well with USB 3... better to buy a long cable. – Attie Sep 5 '18 at 19:25
2

No SATA HDD can operate at USB3 speeds. That has nothing to do with the enclosure, it's a physical limitation of the drive. USB3 goes to 5Gb/sec, which is more than any laptop HDD can do.

  • Thanks. In that case as I mention, how do I ascertain that USB 3.0 enclosure I have does indeed meet USB 3.0 specs? Do I need a SATA III SSD enclosed in it to test? – rajeev Sep 5 '18 at 13:06
  • @rajeev - You can't know, us knowing nothing about the make and model of the enclosure, makes that question impossible to answer. If your current device is not connecting and recognized as a USB 3.0 device, connecting a SATA III SSD, won't resolve that problem. – Ramhound Sep 5 '18 at 13:34
  • 2
    @rajeev Yes you could test it with an SSD. Typically an SSD gets 500-550mb/s and USB 3. If you can manage 500mb/s the enclosure can probably handle the max of USB 3 which is about 575mb/s once you remove overhead. – cybernard Sep 5 '18 at 13:53
  • @cybernard - If they cannot achieve the speeds they should be achieving, with their 2.5" SATA II HDD, why would the 2.5" SATA III SSD behave differently? – Ramhound Sep 5 '18 at 19:50
  • @Ramhound The obvious answer is a sdd is 4-6 times faster. It can't physically change how fast is usb enclosure is, but it will let them know if the enclosure is the bottleneck or not. If the SSD runs at 100mb/s in the enclosure then its obviously the enclosures fault or cable. – cybernard Sep 5 '18 at 19:57
0

When I connect my USB 3.0 flash drive to the USB 3.0 port I get an S against the port in the app.

How do I confirm that the USB 3.0 hard disk drive enclosure is indeed USB 3.0 capable?

This is one way how to determine if your new USB enclosure operates in SS mode, to see the sign "S" in USBDeviceTree viewer. Just like you did confirm this with USB 3.0 pen drive.

If your enclosure show up as "H", then the link falls down to USB 2.0 mode, period, and your bulk transfer rates won't exceed 35-40 MBytes/s.

The likely reason is that either your USB host controller (some no-name "Etron xHCI") has signal integrity or training protocol (or power delivery) deficiency, or the USB-SATA bridge inside your HDD enclosure has some deficiency. One common deficiency is current starvation during spin-up of older SATA drives, since USB 3.0 interface is less tolerant to voltage dips than the companion USB 2.0 link.

If you want to verify if your HDD enclosure is capable of running at SS rates, you either need to find another PC Host with higher port power capability, or try to use a small SSD drive instead of your old mechanical SATA drive, as a test. SSD SATA usually have no problems with power supply and don't have spin-up excessive consumption.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.