0

I'm running gthumb 3.4.5 on fedora 26. It tends to crash whenever I try to play some movie in it. I'm just a java developer, not advanced linux admin, I need some information how these issues are resolved, I totally don't know where to start. Can some one help?

So I have crash report, which does not make any sense (to me): seems like "coredump" without any actual reason, so "gthumb killed by SIGABRT" is the best message I found. When I tried last time to resolve this, I learned (somehow) that GSTreamer is used for playback, and was able to play same movie directly via gstreamer. Now (to check if it's still true) — gst-play gone missing. Ok. So I installed it again according to webpage, now video playback using:

gst-launch-1.0 playbin uri=file://...

or

gst-play-1.0 ...

... works. But it's not crashing, so it's not error on GSTreamer side. OK, good, so maybe GThumb is just buggy in this version(well, at least authors do not know how to handle errors in calls to external libraries, no offense). So I downloaded newer tars, and tried to compile them, but:

checking for gtk+-3.0 >= 3.16... no
configure: error: Package requirements (gtk+-3.0 >= 3.16) were not met:

Package 'gtk+-3.0', required by 'virtual:world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTK_CFLAGS
and GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

So what is this? No backwards compatibility? I have 3.16, but that's no good for apps requiring 3.0? And no trace of 3.0 packages in repos.

--> I'm really missing some crucial knowledge how to address these issues. What should really work automatically requires expert knowledge just to understand what's wrong. So I'm begging for help, since otherwise I have no other option than to reinstall whole system in hope, that there will be version which is OK. And that's not a good way.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.