3

I have a problem with my Chrome browser and my Google Account in general.

Short explanation: pages load in a wrong language - a language, that is not on my language list anymore.

Long explanation: I have had 2 languages added to my Google Account language list (accounts.google.com): English and Polish. I've had that set for a long time and I never had any problems.

One day I changed my Android phone language (which is connected to my Google Account) to Czech. Though, a few days later I switched it back to English.

And that's when the problems started. The Czech language is not listed anywhere - neither on Google Account list, Chrome language list nor on my Android phone, but every time I use Chrome (both on desktop and Android), all websites load in Czech.

I tried everything:

  • adding Czech back to a list and removing it
  • cleaning Chrome or even reinstalling (it so happened, that I even changed my desktop PC operating system - even that didn't help);
  • removing all data from Google Account My History

But the problem still remains - pages load in Czech.

Of course, when I, for instance, login to Facebook it stays in English. It's new pages that annoy me.

This is so unhandy that I was forced to switch to Firefox untill the problem is solved. Any ideas what else I can try?

4 Answers 4

0

As you have told, you have tried all things like switching back to English and other similar procedures and still, your issue is not resolved. In that case, you are left with only one option i.e. you'll have to switch your google account by creating a new one and make settings accordingly i.e. make default language to English and don't disturb the settings.

2
  • Let's not understand the root cause, let's just ignore and wipe everything. Not much of an answer. Put another way, "I have this problem with Windows." Answer: Reinstall OS. Down voting. Oct 3, 2019 at 18:06
  • I also have same problem, and this is not a solution. It's like i have problem with my phone and you tell me to just buy a new one, this is not problem solving. downvoting
    – Sergey Sob
    Nov 1, 2019 at 18:18
0

I had the same problema and I managed to solve it this way:

-Go to C:\Users\\AppData\Local\Google\Chrome\User Data\Default

Find and open "Preferences" file and look for "lan" and see if there's any language you don't want, delete it.

1
  • This did not work for me. I removed all language references other than English. Oct 3, 2019 at 18:10
0

I had tried tried contacting Google about this, but they insisted that all my language settings have been reseted. I also had removed the Google account from all my devices (both browsers and phones), but I still couldn't get it to work.

In the end, I wasn't able to do anything -- I just created a new Google account. Nevertheless, thanks to everyone who tried to help me here ;)

0

I had the same problem but this work for me:

The solution: Go to the three dots and choose Settings. Go to Manage your Google accounts Go to Make Google yours and click: Data & personalization Go to General preferences for the web Go to Languages If your preference is correct anyway, for instance, English then a screen will pop up saying " Not all programs are using English' Click the tab saying CHANGE ALL