0

I feeling I have an opposite effect than most other people that install Ubuntu as a guest OS because I saw many were having trouble with the window being to small after the installation/restart. After trying install the virtual guest additions, I feel things have been much worse. The options for auto resize guest display and virtual screen is all greyed out. I also tried reinstalling virtualbox manager and creating the VM twice again. I just don't know what happen today that cause this issue as things were find in the past with no issues and I have never ever tried to install guest additions before too.

enter image description here

0

Are you running this on a laptop with a high-DPI display?

The display of the guest machine is pixelated, meaning that VirtualBox has scaled up the size of the guest machine so that it doesn't appear too small on the (high-DPI) screen. Unfortunately, it looks like this scale factor is too high and is causing it to exceed the size of the physical monitor. Go to View > Scale Factor and reduce the scale factor so that it fits on the display.

As for adjusting the resolution of the virtual display itself, you may want to try restoring (un-maximizing) the window and manually resizing it. Then again, I have little experience running Ubuntu on VirtualBox (I'm most familiar with openSUSE, which comes with the Guest Additions), so someone else may be able to help you better.

  • On my host Windows machine the display scale/layout size of text,apps option is 150% and resolution is 1920 x 1080 which both are recommended by Windows. I just expieremented with the scale/layout option by setting it to 125%, and my guest OS is to small but not pixelated. I changed back to 150% and tried to open other apps like Google Chrome and Adobe Acrobat and it was fine at 150%. It just the virtualbox manager program/guest OS has a problem with setting that option to 150%. – axesspwns Sep 6 '18 at 22:30
0

I got a okay solution to my problem. I made a clean install Virtualbox and got the newest Ubuntu iso. I lowered the scale factor to 125%. Now my guest OS was normal as expected and not small like I had in my other comment up above. I am able to resize my guest OS manually resizing it myself.

I feel that the issue was the scaling factor on my host OS somehow made an effect on the Virtualbox manager app and in turn my guest OS too.

  • Remember that you can accept your own answer 48 hours after you posted your question. Just click on the check box below the voting controls to accept your answer. – bwDraco Sep 10 '18 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.