2

I used to use virtual machines on my laptop all of the time with no issues. Suddenly, that's changed.

Before you mark this as a duplicate, every single other question about this gave an answer that didn't fix my problem.

YES, the operating system and processor are 64 bit.

YES, this is Windows 10 Home edition. Hyper-V is not even an option to turn off, and I have used bcdedit to turn hypervisorlaunchtype off.

YES, I have restarted multiple times changing different settings.

YES, my hardware supports virtualization; I have used virtual machines on this machine before.

YES, I updated all software.

Whether virtualization is on or not, it DOES NOT CHANGE and the 64 bit options are not visible.

It might be noteworthy to mention that when virtualization is ENABLED in the UEFI, I get an error that "raw mode unavailable courtesy of hyper-v" and when DISABLED the virtual machine actually boots into Xubuntu (but obviously gives an error that a 64 bit processor is needed for a 64 bit os). I do not know why it boots when virtualization is off, given that it usually needs to be on, but either way it's not working.

1
  • I may have found a fix. One second. Sep 6, 2018 at 20:16

1 Answer 1

2

I found one answer I hadn't seen in my previous searches (I scoured Google for hours and finally found this): Core Isolation was turned on.

Core Isolation uses virtualization technology, and therefore hogs VT-x.

I had changed this setting recently for unrelated reasons.

Hope this helps someone else find this answer quicker!

2
  • 1
    where is that setting?
    – Aganju
    Sep 6, 2018 at 23:18
  • If you search "Core Isolation" in Windows 10 it should take you to it. I believe (I'll confirm later) it's under Windows Security->Processor options. If you don't see it then virtualization is not enabled. Sep 9, 2018 at 4:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.