-1

Since about 2 weeks my computers clock does not update on boot anymore for some reason. It does not fall back to a certain date and the CMOS Battery is at 3.288V (checked both with Open Hardware Monitor and in the UEFI) so I don't think that the battery is the issue. It feels like what happens is that when I shutdown my computer that time is saved and simply used when it boots again despite me having activated windows automatic time setting. I can manually refresh the clock by turning that setting off and on again which is rather annoying to do every time.

I have fast startup turned off. It was activated when I first investigated this issue and I disabled it because I had issues with it in the past already.

What is causing this behaviour and how can I solve it?

  • My first suggestion would be to try a restart instead of a shutdown. If that doesn't get it working, perhaps going to "Control Panel" -> "Clock, Language and Region", then clicking "Set the date and time", go to the "Internet Time" tab, click "Change settings..." and change the server. (Using the "Update now" button usually says there was an error but it works anyway.) – Andrew Morton Sep 8 '18 at 12:30
  • Instead of what shutdown? I probably should have explained better: If I go to bed in the evening, I shutdown my computer and flick the switch of my powercord (else I have a small LED turned on on the motherboard the whole time). It would not make sense to restart at that point. Regarding the server I also have my doubts. If I switch off the auto-time feature and on again, I get the correct time so the server does not seem to be the problem, or is it? – geisterfurz007 Sep 8 '18 at 13:00
  • Your problem isn’t really clearly defined. The computer should keep the time when the power is turned off. If the time isn’t mostly accurate when you turn the computer back on then there is something wrong with the motherboard. So answering why windows won’t update the time right away for you doesn’t solve the problem. This shouldn’t be happening in the first place. You’re asking like it’s an OS issue but it’s a hardware issue. – Appleoddity Sep 8 '18 at 13:40
  • @Appleoddity I did expect it to be a windows problem because I thought that windows would synchronize the clock on startup. I let my computer be down for an hour without power on the power supply and the time was roughly 25 minutes after I turned it off when I just started it. You mention that it is a hardware issue which would fit a few other problems I had recently (keyboard is still being powered, boot doesn't complete). Is there anything I can check more precisely? Chances are also (and not that low) that I tortured my OS enough as I have the same for the third set of hardware now. – geisterfurz007 Sep 8 '18 at 14:11
  • I had this problem once, in troubleshooting I changed the time server. The problem went away and I never did go back and figure out the root cause. At one point in history ntp servers had limits to the number of requests you could make a day, I haven’t read any T&C lately to see how that’s changed because a network these days could have many devices that need to get time updates. – Tyson Sep 8 '18 at 14:31
-2

I think the motherboard battery is dead and it does not keep time when you shut it down try replacing motherboard battery

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.