1

I am trying to access a drive that is shared (G:/ drive) from a Mac. The windows computer is using Windows 10. Here are some infos about both computers.

Windows

  • All sharing options are activated in the Network Center -> Advanced Parameters (private, public and all networks)
  • Firewall is disabled
  • Workgroup name is: WORKGROUP
  • G:/ is shared with Everyone and having all autorisations
  • This PC's name is Central

I've tried accessing this drive with another Windows computer in the same network and it worked. It doesn't work for the Mac.

Mac

  • File Sharing is activated
  • SMB is activated and my Mac User is the one that can use it
  • Workgroup name is : WORKGROUP
  • Windows' PC name Central is actually found by the Mac

When I tried to connect to Central, that being by either it's name or the IP adress (IPV4), it shows me connection failed. It's instantaneous, it doesn't even seem to attempt to find something.

For reference i've used this guide amongst others: https://support.apple.com/en-ca/HT204445

1

It might help to enable SMBv1, which is by default not installed in Windows 10 for security reasons.

This is the procedure :

  • Run Control Panel -> Programs and Features
  • Click Turn Windows features on or off
  • Click next to SMB 1.0/CIFS File Sharing Support so it marked as checked
  • Click OK and allow boot

If this does not solve the problem, disable SMBv1 using this same method by unchecking the option.

| improve this answer | |
  • @ harry - I bow to your superior knowledge, but am reminded of a similar issue I had a & wondered if it was possibly relevant - superuser.com/questions/888923/… – Tetsujin Sep 9 '18 at 16:29
  • 1
    @Tetsujin: I don't think so. If I remember right, SMBv1 was enabled by default in Windows 7. – harrymc Sep 9 '18 at 16:49
  • OK, no worries - it just sparked a vague memory. – Tetsujin Sep 9 '18 at 16:58
  • Thank you for your answer! That was exactly what I needed to enable to make it work. – Alexandre Fernandes Bartolomeu Sep 9 '18 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.