0

I have a Fit-PC3 with a Phoenix BIOS (Securecore Tiano v2.1), and when I turn it on with a Samsung 3TB USB external hard drive (similar to this) plugged in, it freezes on the BIOS screen (I am unable to press F2 to enter the BIOS setup).

When I unplug the drive, it boots fine. I can then plug in the drive later, and it works perfectly.

The drive has its own power supply plugged in to the mains.

I have changed the boot order in the BIOS, so my internal HD is listed first, and the external HD is listed second, and marked as disabled (there is an "!" next to it).

I have turned off UEFI boot and turned on Legacy mode.

I have overwritten the master boot record on the drive with zeroes using dd.

I have tried plugging it into different USB ports.

Possible duplicates: Ext HDD = Frozen @ Splash Screen, Shuttle FB51 mobo does not boot with external USB drive attached, Troubleshooting a failed hard-drive that halts BIOS

The results are the same if I plug in the hard drive via a USB hub but when plugged in to another PC (ASUS BIOS) that PC boots fine.

Any ideas how to get it to boot?

  • What is your operating system and is this happening with both USB2 and USB3? I once encountered a PC that couldn't boot with anything connected on USB3, and the problem went away when upgraded to Windows 10. – harrymc Sep 12 '18 at 15:10
  • 1
    Is the HDD being powered through the USB port? Maybe it's drawing too much power. – Daniel F Sep 12 '18 at 22:26
  • I have seen this a few times..many years ago. I don't recall what I did as a workaround besides unplugging it and plugging it in when it was on. I think one thing I might've tried was plugging in a USB hub and then plugging the device into the USB hub, that might have worked i'm not sure. You could try that – barlop Sep 12 '18 at 22:34
  • The OS is Lubuntu 18.04 – Andy Balaam Sep 13 '18 at 6:32
  • The HDD is powered via a separate power adapter plugged in to the mains. – Andy Balaam Sep 13 '18 at 6:33
1

Here are some suggestions, in the hope that they will help :

  • Update the BIOS as detailed in this Fit-PC3 Support page, if a newer version to yours does exist.
  • Enter BIOS setup and set Legacy support for UMS (USB Mass Storage) devices to Disabled, if you have such an option. This will only prevent your PC from booting from USB devices, which is not a problem. This only affects the BIOS, while Windows will still detect all disks.
  • Among the many BIOS versions in existence, the above setting might have other names such as "Legacy USB storage detect", or "Legacy USB Support" or "USB Device Legacy Support". Or they might be separate options. Sometimes these settings may be on an "Integrated Peripherals" page in the BIOS.
  • Reformat the disk using the Fit-PC3 computer.
  • Try a newer enclosure (if it is not new). I just lately encountered here a post where an enclosure that internally used 32-bit addressing had a problem with a disk larger than 2 TB.
  • Replace the disk, if still under warranty (but I don't really expect this to help).
  • Admit defeat and never boot with this disk turned on.
  • I tried setting Legacy Boot to Disabled, and it would not boot from the internal SSD. It showed me a menu with only the internal SSD listed, but when I selected that it just went black and showed me the menu again. I got the same behaviour when I enabled UEFI boot (and left legacy disabled). – Andy Balaam Sep 16 '18 at 16:40
  • Regarding a new enclosure: the drive works on my friend's computer, and is fine on this one after boot time, so I think it must be mostly OK? – Andy Balaam Sep 16 '18 at 16:42
  • I am nervous to update the BIOS (especially as the page you linked is for Windows only and I only have Linux), and I would prefer not to reformat the disk, so I think I am going to have to take your last option. Thank you for the time you have put into this. – Andy Balaam Sep 16 '18 at 16:44
  • 1
    The BIOS is common to both Windows or Linux and can usually be launched from a boot USB. But I understand, since a bad BIOS update can brick the computer. I had once the same problem on Windows, tried everything except the BIOS update, and finally I also took the last option ... – harrymc Sep 16 '18 at 16:48
0

My experience with this and my observations. I had a conflict with USB 2.0 and 3.0 that would stop it from booting up. BIOS firmware update can solve 2.0 and 3.0 USB conflicts. I would advise to be certain that 2.0 and 3.0 are correct.

-1

Had the same problem with pc freezing at bios screen everytime ext hdd was connected. This is what worked for me ; - just purchased a Dell Optiplex 9020 SFF [used] - ext hdd [which I was using previously] was now a problem, computer would not boot when it was connected.It would freeze at the Dell BIOS screen.

SOLUTION; - using Aomei Partiton Assistant Pro, I noticed that c drive [os] was MBR, 2nd drive was MBR, 3rd drive [ext hdd] was GPT. Using Aomei program, I converted the problem ext hdd which was MBR to GPT with no loss of data. - went into Dell BIOS and disabled Legacy ROM & USB Boot Support. - BINGO! pc will now boot as per normal with ext hdd connected permanently to it. Hope this helps you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.