1

This question already has an answer here:

With the current stable Chrome version 69,

when I surf to https://www.google.com the browser only shows google.com in the URL field.

I don't want Chrome to hide the protocol and I don't want Chrome to hide the subdomain.

How can I change these settings?

marked as duplicate by music2myear, bertieb, Toto, fixer1234, Twisty Impersonator Nov 8 '18 at 21:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

6

Taken from https://www.bleepingcomputer.com/news/google/chrome-69-removing-www-and-m-subdomains-from-the-browsers-address-bar/

Open the Chrome browser and enter chrome://flags/#omnibox-ui-hide-steady-state-url-scheme-and-subdomains into the address bar. Then press Enter.

Chrome will open a page that shows the "Omnibox UI Hide Steay-State URL Scheme and Trivial Subdomains" setting. Change this settings to Disabled.

@Google: For me this is a bug too. This "feature" is confusing and wrong, it should be removed.

www.domain.com, m.domain.com and domain.com are three completely different hostnames.

  • this isn't working for me... I'm on Mac OS 10.13.6 running Chrome 70.0.3538.67. I have #views-browser-windows enabled and #omnibox-ui-hide-steady-state-url-scheme-and-subdomains disabled. See i.imgur.com/LwPxeQjr.png. Any clue how to get it to work? – CharlieC Oct 23 '18 at 19:10
  • Turns out #upcoming-ui-features needs to be disabled as well to get this to work. – CharlieC Oct 23 '18 at 19:22
  • 1
    The correct URL is chrome://flags/#omnibox-ui-hide-steady-state-url-scheme as of Chrome 73. They split out the "trivial subdomains" part into its own setting, as well as adding another setting that hides query args. – CoreDumpError Jan 31 at 20:11
1

Here is what's needed to get the scheme (aka protocol) and 'trivial' subdomains to be shown on Mac OS 10.13.6 running Chrome 70.0.3538.67:

  • chrome://flags/#views-browser-windows set to enabled
  • chrome://flags/#omnibox-ui-hide-steady-state-url-scheme-and-subdomains set to disabled
  • chrome://flags/#upcoming-ui-features set to Default or disabled.
  • 1
    Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Oct 23 '18 at 20:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.