0

I am using a synology NAS that has a L2TP/Ipsec VPN server running. The NAS is located in a network with a FritzBox router.
Now I am in another network that is also established with a FritzBox router. From here I can connect to the VPN via debian and android. But on one of two Windows 10 machines it is not working.
And now I am curiouse, why the one windows 10 will not connect. To fix this one computer is my question in this post.

I have set up the registry:
DWORD AssumeUDPEncapsulationContextOnSendRule in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent with the value 2.

The services are running:
IPsec Policy Agent and IKE and AuthIP IPsec Keying Module

I configured the network adapter:
adapter settings
(Sorry that it is german.)

I checked the credentials (username, domain, password, ...) several times.
Also the preconfigured key is entered correctly.

But still I get this message:
error message
(image from another post, but it is the same message that I get, but in english.)

No error code that I can follow.

The computer that it is not working on is a Surface Pro 4, newest updates from yesterday evening.

Some things that I tried (none of them had any effect on the problem):

  • Going to the device manager -> networkadapter -> delete all WAN Miniport -> action -> search for changed hardware
  • disabeling the Xbox Live-Networkservice (was not running in the first place)
  • I tried to restart the DHCP-Client, but permission denied with code 4. So I could not restart. Trying to fix this permission issue also did not work (more permissions in the registry and adding some extra users to the admin group like system and so on.). So I tried other things.

What am I missing? Why is this setup working on several windows 10 computers, but not on this one surface?

thanks and greetings

0

If your Windows 10 Version matches 1709, try uninstalling Update KB4457142.

I've had a similar Problem with IKEv2 yesterday and resolved it by temporary uninstalling the Update.

  • hi, thanks for the answer. But unfortunately I am using 1803. And uninstalling also had no effect. But worth a try :) – christopher2007 Sep 13 '18 at 21:28
0

We've had similar problems with VPN/IKEv2 and KB4457142 on version 1709. Removing KB4457142 fixes the problem. Version 1803 with the equalent KB4457128 works fine with VPN/IKEv2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.