0

I am trying to mount an .iso image into virt-viewer so I can boot a VM off of it to recover a lost root password. However, it appears that virt-viewer can only share USB devices, and not ISO files. I know it is possible to mount an iso file as a loopback device, but is it possible to feign a USB device (make the system present the iso file as a usb disk).

Normally I would try recovering using GRUB, but it appears not to be working (the init=/bin/sh kills console access when I try to run it, using break.rd enforcing=0 is ignored and goes directly to the login prompt). The remaining option is booting off of an iso.

I have access to linux, osx, and windows machines so a solution for any of them would work.

| improve this question | | | | |
  • Does it have to be USB, or will any removable disk do the job? – harrymc Sep 12 '18 at 15:23
  • Specifically USB. – Matthew Sep 13 '18 at 4:47
0

Have you tried virt-rescue? I haven't tried it myself, but it seems to indicate that you can get a recovery shell. I would think that you can reset the password for the root account that way.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.