When I run adb logcat nothing happens but when I run it in the adb shell then it works ok. Those are the outputs:

eduardo@debian:~$ adb devices
List of devices attached
LGM250CE6PYLFQGU9P  device

eduardo@debian:~$ adb -s LGM250CE6PYLFQGU9P logcat -t 1
eduardo@debian:~$ adb -s LGM250CE6PYLFQGU9P shell -t "logcat -t 1"
--------- beginning of main
09-12 20:52:09.511   380   380 I DisplayDevice: [Built-in Screen (type:0)] fps:1.987004,dur:1006.54,max:515.21,min:491.33

And this is my adb version.

eduardo@debian:~$ adb --version
Android Debug Bridge version 1.0.40
Version 4986621
Installed as /home/eduardo/Android/Sdk/platform-tools/adb

The same behavior happens on Windows and Debian.

Is it something wrong with adb or my device?

1 Answer 1


I have the same issue when I upgraded platform-tools from 28.0.0 to 28.0.1 on Debian and Windows yesterday.

By seeing your Android Debug Bridge version and the date of your question, I suppose you have upgraded your platform-tools to 28.0.1.

You can try to do a workaround: downgrade your platform-tools to 28.0.0.

  1. Download the platform-tools 28.0.0 from Google's android repository

  2. Unzip platform-tools_r28.0.0-*.zip and try to run the adb from platform-tools/adb

  3. If it works, you can overwrite your current Android SDK's platform-tools by copying the unzipped platform-tools folder into your Android SDK Root directory

  4. Try to avoid platform-tools to update to 28.0.1 again until this issue is solved


After reading the link in the comment of @Eduardo, it seems that platform-tools 28.0.1 exposed a bug on LG devices when running adb logcat.

The maintainer of adb suggested the following workaround if you want to run newer versions of platform-tools:

Use adb shell -x logcat instead of adb logcat.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .