4

I have a couple Fn shortcuts on my F1-F12 keys. F12 is the calculator, F11 puts my PC to sleep. The amounts I confuse those keys by accidents are astronomical.

How can I disable my suspend/sleep key entirely, or optionally map it to something else?

I found this but it's Windows and this but it doesn't work:

$ gsettings set org.gnome.settings-daemon.plugins.power button-suspend "nothing"
No such key “button-suspend”
$ gsettings set org.gnome.settings-daemon.plugins.power button-sleep "nothing"
No such key “button-sleep”
$ gsettings set org.gnome.settings-daemon.plugins.power button-hibernate "nothing"
No such key “button-hibernate”

I'm on arch-linux using Gnome 3.28.3. I checked everything in gnome-settings and gnome-tweak-tool without success. A search for suspend or sleep in dconf-editor comes up with only this, and I'm sure this isn't what I'm looking for: enter image description here

I tried to find out the name (?) of the key using xev, in an attempt to give xbindkeys a try to re-map the key, but it doesn't work with the calculator shortcut (nothing shows up in xev) so I assume it won't work with the sleep one either (I'd rather not try).

Note: I do not want to disable sleep/suspend all-together. Just that special keyboard key.

Edit: I'm now on the newest gnome version (3.32). Issue still persists.

1

According to https://wiki.archlinux.org/index.php/GNOME GNOME 3.24 deprecated:

  • org.gnome.settings-daemon.plugins.power button-hibernate
  • org.gnome.settings-daemon.plugins.power button-power
  • org.gnome.settings-daemon.plugins.power button-sleep
  • org.gnome.settings-daemon.plugins.power button-suspend

Try

gsettings set org.gnome.settings-daemon.plugins.power power-button-action 'action'

where 'action' can be nothing, suspend, or hibernate

Details at: https://wiki.archlinux.org/index.php/GDM

1
  • Tried it. Now when I press the button on my keyboard the screen goes black, then only the cursor shows, then all black again, a console window shows for a fraction of a second, all black with cursor again, then I'm back in my gnome-shell as if nothing happened. I'd certainly say this is worse than before, lol. Can this be related or is something else messing up here? Never happened before, usually just went into suspend normally. I've set it to 'nothing'. – confetti Sep 19 '18 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.