so I have a computer running Linux Mint and to play loss-less audio-files I use DeaDBeeF, which I have configured to not use ALSA up-sampling in order to listen to allow my external Audio Interface(Musical Fidelity V-Link) to handle the varying bitrates.

I have gotten used to the side-effect, that the OS can't use the card simultaneously for general sound output and I actually rather like, that the soundcard get's reserved which blocks out any other applications sound.

The problem is I have, is that sometimes I just can't start playback of any song, as if the soundcard were being used even though I can't hear any output and close all the applications that could be reserving the soundcard.

Weirdly, neither disconnecting and reconnecting the interface, nor setting another output device in system-audio settings seem to resolve the problem and so this forces me to restart my computer every time the issue occurs.

While it would be convenient to resolve the issue per se, as a Linux enthusiast I am keen to understand, not only how to solve it but also what is causing the issue and possibly other ways of debugging it.

If I run deadbeef from the terminal, I get the following error:

convgui: gtkui plugin not found
plugin Converter GTK3 UI failed to connect to dependencies, deactivated.
plugin Playlist browser GTK3 failed to connect to dependencies, deactivated.
shellexecui: can't find gtkui plugin
plugin Shellexec GTK3 UI failed to connect to dependencies, deactivated.
gtkui plugin compiled for gtk version: 2.16.0
connecting button tray signals
could not open audio device (Device or resource busy)
could not open audio device (Device or resource busy)
streamer: failed to start playback (start track)

this supports my theory of the resource(audio-interface) being reserved, but I don't know how I can further investigate the issue and I don't understand, why dis and reconnecting the card with different global audio settings(i.e. tell the OS to use built-in audio) doesn't resolve it.

In my understanding all applications put out to ALSA and therefor ALSA should be the only programm using the interface.

Any pointers on how to further investigate or resolve the issue would be appreciated.here's a screenshot of how I configured deadbeef

1 Answer 1


To find out which processes are accessing sound devices, run:

lsof /dev/snd/*


fuser /dev/snd/*

(fuser shows only PIDs, not names, but has a --kill option …)

  • Ok, so that was the missing Link. Turns out killing/restarting pulseaudio does the trick. I should probably delve somewhat deeper into Linux Audio. Thanks
    – MTTI
    Commented Sep 16, 2018 at 14:06
  • Check exit-idle-time in /etc/pulse/daemon.conf.
    – CL.
    Commented Sep 16, 2018 at 17:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .