3

In addition to that, I cant move a file or folder onto the desktop. It just does an animation that brings it back to the file explorer.

Also I have lost some options when right clicking on the desktop. There's supposed to be an Open in terminal option but the only thing I get is this

The options I get when right clicking on the desktop

This issue occurred when I did apt-get dist-upgrade and some other apt-get commands. My GNOME version is 33.0 if that is necessary.

2
3

Gnome 3.28 removes the option to display desktop icons You have GNOME version 3.30 and it's weird that you still have problem.

Try this extension:

https://extensions.gnome.org/extension/1444/desktop-icons-enhanced/

or this:

https://extensions.gnome.org/extension/1465/desktop-icons/

1
  • just wait for the September 30 release – Charalambos Papa Sep 22 '18 at 16:23
1

This issue is fixed in 3.30.1

I just updated mine and they came back

apt-get dist-upgrade
apt-get update
apt-get upgrade
then apt autoremove if you want to clean
Rebooted and icons were back
0

There may be an issue with desktop icons, as you mentioned in you comment. However, be aware that many distros using the latest version of Gnome disable moving files and folders to the Desktop. This "feature" can be disabled by tweaking Gnome settings.

Personally, I find it very strange that a distro/Gnome would set this as the default. People have been using their Desktop to store files and folders for over 3 decades now. Why do they think k this change is necessary and mandatory?

0

noticed this as well (Gnome version 3.30.0) https://www.omgubuntu.co.uk/2018/01/gnome-desktop-icons-removed-3-28

So, either bypass with extensions, or adapt to the new changes.

Not the answer you're looking for? Browse other questions tagged or ask your own question.