11

I rebooted my machine (Mac OS X El Capitan 10.11.6 15G31) and re-opened Google Chrome version 69.0.3497.92 (Official Build) (64-bit). It took me to the newly-updated version of the browser. When I went to Chrome -> Help -> About Google Chrome, I accidentally clicked on the "Automatically update for all users across all devices" line, and it changed to "Automatic updates are turned on". I don't want to automatically update Chrome across all of my devices. I can't see any place to turn this setting off. What do I do??

enter image description here

9

Depends how you setup auto update. If it's for you only:

enter image description here

, then just:

sudo chmod -R 000 ~/Library/Google

To revert it back:

sudo chmod -R 755 ~/Library/Google

If it's for all users:

enter image description here

Then you can change permission as above for /Library/Google/ or even remove it completely.

sudo rm -rf /Library/Google/

After you will see enter image description here or enter image description here

depending on choosing method.

| improve this answer | |
3

Google Chrome downloads updates automatically from https://tools.google.com/service/update2. Spoofing a DNS record of the respective host will prevent the updates from being located.

Add the following mapping to the hosts file /etc/hosts:

0.0.0.0 tools.google.com

Shell script chrome_update_block.sh automates this configuration.

Chrome will no longer be able to fetch updates after restart: enter image description here

Caution! GA Opt-out and other online tools on the same domain will become inaccessible.

| improve this answer | |
1

I think this should work to disable background updates:

launchctl disable user/`id -u`/com.google.keystone.system.agent

| improve this answer | |
0

I generally approve software auto updates, but Chrome dev ran out of OKR and adds crap features like hide www and protocol and there's no way to revert it in v79 and above, and removed use tools like chrome://net-internals

To disable update

chmod 000 '/Applications/Google Chrome.app/Contents/Frameworks'

To disable the updater:

sudo chmod -R  000  ~/Library/Google/
| improve this answer | |
-1

Hey bro unfortunately google hided it so deep For mac os try to find google folder in library which contains chrome update folder just empty this folder and then lock it with get info ( right click on upchrome update folder then get info n hit locked) If u can't find it so try to use clean my mac app just open it n hit uninstaller n then mark chrome so u will find all chrome files n folders just mark on chrome update folder n choose reveal in finder n do the above steps I hope that will help

| improve this answer | |
  • 1
    People are more likely to read your answer if you format it so it is not a wall of text. Please read Markdown help and edit your answer to add paragraphs and bullet points ... and please don't use txt speak. – DavidPostill Sep 26 '18 at 6:14
-1

Open terminal and enter

defaults write com.google.Keystone.Agent checkInterval 0
| improve this answer | |
  • this used to work, but not anymore. – marathon Jun 9 '19 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.