1

I've disabled third party cookies on google chrome but i can still see the cookies being set in the DevTools application tab.

  1. I loaded a web page, it led to cookies being set for various domains.
  2. Then i deleted only the cookies of a one third party domain.
  3. Then i blocked third-party cookies in chrome settings.
  4. Then refreshed the page.
  5. I see the cookies of that third party domain that i'd deleted being set again.
  6. Can anyone point out if this is expected?
0

Disabling third party cookies only disables their installation. Cookies that already exist are not deleted.

You may delete all cookies in Chrome, but beware, since this will most likely invalidate some of your stored logins.

For more information see the Google article Clear, enable, and manage cookies in Chrome.

  • 1. I loaded a web page, it led to cookies being set for various domains. 2. Then i deleted only the cookies of a one third party domain. 3. Then i blocked third-party cookies in chrome settings. 4. Then refreshed the page. 5. I see the cookies of that third party domain that i'd deleted being set again. 6. Is this expected? – priyankatanvani Sep 19 '18 at 6:32
  • Might require restart of Chrome. – harrymc Sep 19 '18 at 6:43
  • i just restarted chrome and tested again. Same thing. I'm using chrome version 68. Tested the same thing on chrome 62, this issue is not coming. 3p cookies are not getting set again. – priyankatanvani Sep 19 '18 at 6:57
  • I tried on a separate machine with chrome 69, this issue is not happening there. Will update chrome on my machine and test again. – priyankatanvani Sep 19 '18 at 7:05
  • The issue is not happening for chrome 69. Thanks! – priyankatanvani Sep 19 '18 at 7:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.