0

For logging into my shared hosting server using ssh, I have generated the public/private key, authorised the public key, then downloaded the public and private key and finally moved those keys to the .ssh folder on my desktop which is running ubuntu.

Following are the permissions for my keys:

-rw-rw-r-- id_rsa

-rw-rw-r-- id_rsa.pub

When I try to ssh into my server, I am being asked for a password with a prompt that says "An application wants to access the private key but its locked".

I tried my login password but its not working. What am I missing here?

(reposted from stackoverflow)

  • ...and what are the permissions of the $HOME/.ssh directory? The .ssh folder on your desktop is completely irrelevant and will not be used (unless you did some questionable things to ssh itself). – jvb Sep 18 '18 at 12:20
  • jvb - the permission of .ssh directory is rwx------ – Sid Sep 18 '18 at 14:55
0

I believe that this is happening because the gnome-keyring daemon is managing the ssh keys (it shouldn't since ssh already has an agent). You can tell the daemon to stop doing this by issuing this command:

sudo gconftool-2 --set -t bool /apps/gnome-keyring/daemon-components/ssh false

I have also seen this version of the command (source) :

sudo gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.mandatory --type bool --set /apps/gnome-keyring/daemon-components/ssh FALSE
  • harrymc - I used the commands but its still asking for the password. When I run sudo gconftool-2 --get /apps/gnome-keyring/daemon-components/ssh, it returns false. – Sid Sep 18 '18 at 14:51
  • Did you try the other commands from the link? – harrymc Sep 18 '18 at 14:54
  • Yes i tried all those commands. – Sid Sep 18 '18 at 14:57
  • Gnome is a moving target, and gnome-keyring is unmaintained, so it's difficult to find a permanent solution. Try this answer for a workaround by respawning gnome-keyring-daemon, and for removing ssh as component of Gnome keyring. – harrymc Sep 18 '18 at 15:10
  • Its not working. I will try it the other way around - generate the keys locally and then upload the public key on to the ssh folder on the server. Thanks anyway. – Sid Sep 18 '18 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.