I've been trying to install Linux Mint to a 20GB partition on a USB drive (Kingstion DT Elite G2 - 64GB) on a laptop (HP Pavilion 10 TS Notebook PC) but have always gotten the following error message:

The package grub-efi-amd64-signed failed to install into /target/. With the GRUB boot loader, the installed system will not boot.

After looking at the log, the post-install script returned exit status 1.

I have tried:

  • Installing Linux Mint 18.3 instead of Linux Mint 19 v2.
  • Installing GRUB to /dev/sdc2 instead of /dev/sdc.
  • Unchecking "Install additional drivers for hardware, Flash, and multimedia".

I couldn't get GRUB to install. The farthest I got was copying GRUB files to the Linux Mint partition and booting that (it would only boot in BIOS compatibility mode), but I always got a message saying Could not load operating system.

What can I do to boot Linux Mint on my USB drive?

  • Have you a UEFI partition on the disk? See this answer for details. – harrymc Sep 21 '18 at 18:24
  • @harrymc I didn't. Adding it worked! I guess I didn't need the bounty then. :[ – Zackary Sep 21 '18 at 20:50
  • The bounty is for attention-getting and it worked ... I'll put up an answer tomorrow about that. – harrymc Sep 21 '18 at 21:23

This problem happens when manually creating the disk partitions during a UEFI enabled installation.

The point is that a UEFI installation requires the prior creation of a UEFI partition. The error is generated when the installer cannot find a suitable partition on the installation disk.

See for details the article Creating an EFI System Partition, but in short the size of the partition is recommended as 200 MB, of type FAT32, and flagged as "boot". The partition editor of the installer may take care of all the details (except the size) if it supports a partition type of "UEFI".

For one detailed description of the installation process by a user who also encountered this same error, see on Ask Ubuntu this answer.

| improve this answer | |

Did you try install from cd/dvd-rom ?

I try to install Ubuntu Desktop 16.04.5/17.10/17.10.1/18.10 via PXE Server have same issue.

PS: I use "Erase disk and install Ubuntu" to install, it will create an EFI System partition. So, it's not partition problem.

After Boot into Live-OS,I try to setting network for Internet. Then click install to install OS via Internet instead of local PXE Server. This issue was solved.

Refer this: http://linuxbsdos.com/2017/08/29/solution-to-grub-efi-amd64-signed-package-failed-to-install-into-target/comment-page-1/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.