0

Windows 10 Ubuntu bash failing to install packages. Whenever I try install new package with below command, getting same error.

root@VASI-HOME-PC:/mnt/c/Users/vadap# apt-get install atom
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package atom

This is not just with atom pacakge but i tried installing other packages like pip as well and received same error.

  • 1
    The error message you received, indicates Atom is required, which means the package you are trying to install has a GUI. That isn't going to be supported by WSl out of the box. In other words, you are not going to be able to install any package, that requires Atom. – Ramhound Sep 19 '18 at 19:25
  • @Ramhound I have tried to install pip and few other packages. I have received the same error. Does it mean all of them had GUI ? – Devoloper250 Sep 20 '18 at 15:59
0

The error you're getting is because "atom" isn't part of the default packages, but WSL does not support graphical applications like Atom so it would never work anyway.

I would recommend installing it for Windows which is available from their website atom.io.

To make sure a package is actually in the package system you can use apt search <whatever> or for a simpler output apt-cache search <whatever>.

NOTE: Do not do the following, but for completeness sake I'll add how to actually install it:

You need to add the atom repository with the following command: sudo add-apt-repository ppa:webupd8team/atom

After that you can install it by first updating the search cache with apt-get update and then installing the package with apt-get install atom.

0

Executed below 2 commands and then I was able to install the packages.

sudo apt update

sudo apt install python3-pip

Source - https://linuxize.com/post/how-to-install-pip-on-ubuntu-18.04/

  • This answer is unlikely to be well recieved, unless you provide the relevant information from the link, like what you actually did in the body of the answer. – Ramhound Sep 20 '18 at 18:24
  • Thank you @Ramhound . I have updated the steps executed and later I was able to install the packages like pip. – Devoloper250 Sep 20 '18 at 18:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.