1

I took the following steps to create a dual boot setup on my SurfaceBook with Windows 10 and Ubuntu 18.04

1) Installed Windows 10

2) Suspended Bitlocker

3) Installed Ubuntu 18.04 from a USB bootable thumbdrive alongside Windows 10. This completed successfully and I restarted.

4) Presented with GRUB screen to choose OS and chose to enter Windows10 (worked this one time) which automatically re-enabled Bitlocker.

5) Restarted which presents the GRUB screen, I selected Windows10 and was presented with the Bitlocker recovery screen

6) Entered my recovery code and clicked the restart button

7) Shown GRUB screen and picked Windows10 again

8) Presented with Bitlocker recovery screen ....

9) This loop continues indefinitely

I am stuck entering the 48-digit Bitlocker recovery code indefinitely, never making it through to Windows. I tried using the Windows command prompt to enter 'manage-bde -unlock <48 digit code>', but when I run 'manage-bde -status', the encrypted windows volume is not even listed as an option. It does not see the Windows partition at all.

I can enter and use Ubuntu with no issue. Had I disabled Bitlocker, there would be no issue. It's the Bitlocker part that's causing me all the headache.

What are the proper steps to get this dual boot working with Bitlocker?

1

The fix is to suspend Bitlocker then resume Bitlocker. That will reset the flag that keeps asking for the recovery key.

0

I had same issue, after installation of Ubuntu as dual boot OS I had to enter the 48-digit BitLocker recovery code indefinitely.

My stuff is XPS 9670 / Windows 10 Pro / Ubuntu 19.04

Problem solved by doing these steps:

  • Suspend (not disable) BitLocker by using BitLocker manager from Windows
  • Reboot and go into my Bios to disable TPM
  • Boot on Windows
    • I had to login with password as fingerprint and pin did not worked, due to TPM disabling
    • At this step, you can't re-enable BitLocker as it depends on TPM which is disabled
  • Reboot and re-enable TPM on BIOS, Save and exit
  • Boot on Windows and check that BitLocker is running again (it should have been automatically re-enabled)
  • Then I boot Ubuntu and then Windows without any BitLocker troubles :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.