0

I use Kodi on LibreELEC on a Raspberry Pi 3 connected to a high-end Samsung television set with HDMI. The TV is generally working well for other sources, but Kodi's colors look washed out. Everything is just too bright and the gamma settings look off. For instance, the black vertical bars when watching 4:3 content appear as gray, not black. What can I do?

1

This problem can be because the Raspberry Pi's HDMI default configuration isn't working for your TV. I have observed this problem for several different Samsung sets, both old and new.

HDMI pixel encoding

Edit the hdmi_pixel_encoding property in config.txt. Normally on Linux this is located in /boot/config.txt but on LibreELEC, which has a mostly read-only file system, the location is /flash/config.txt. You also need to ensure you have editing rights:

mount -o remount,rw /flash
nano /flash/config.txt

In the bottom of the file, add a line with hdmi_pixel_encoding=2 and then reboot. If 2 isn't working, there are other values to try from the documentation:

  • 0: default (RGB limited for CEA, RGB full for DMT)
  • 1: RGB limited (16-235)
  • 2: RGB full (0-255)
  • 3: YCbCr limited (16-235)
  • 4: YCbCr full (0-255)

Source label

You should check if you have labeled the Pi as a PC (or DVI-PC) source, because this for some reason makes Samsung disable many capabilities (like the Auto-motion feature and most customisation options) and dramatically changes the way the TV image and colors are displayed. Whether this is desired depends on the actual set.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.