3

I'm trying to install a bioinformatics tool, called Daccord on my Mac.

Unfortunately my computer savvy is very limited and my troubleshooting is pretty much trial and error.

The README says:

daccord needs libmaus2 https://github.com/gt1/libmaus2. libmaus2 needs to be built with support for the GMP library. When libmaus2 is installed in ${LIBMAUSPREFIX} then daccord can be compiled and installed in ${HOME}/daccord using

autoreconf -i -f
./configure --with-libmaus2=${LIBMAUSPREFIX} \
    --prefix=${HOME}/daccord
make install

I did install libmaus2 (at least I hope I did), I also installed GMP, but I have no idea whether libmaus2 was "built with support for the GMP library".

My guess is that I have to replace ${LIBMAUSPREFIX} with the right path? Maybe ${HOME} too.

I tried /usr/local/bin because the libmaus-README said:

By default, make install installs the package's commands under /usr/local/bin, include files under /usr/local/include, etc.

I also tried the path of the libmaus release file.

So far the result is always:

configure: error: Package requirements (libmaus2 >= 2.0.352) were not met:
No package 'libmaus2' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables libmaus2_CFLAGS
and libmaus2_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Now, I additionally tried to set the PKG_CONFIG_PATH using

export PKG_CONFIG_PATH=/usr/local/lib

/usr/local/lib contains libmaus2 and a lot of other files starting with libmaus2 so I would guess that's the right path. But

./configure --with-libmaus2=/usr/local/lib --prefix=${HOME}/daccord

or

./configure --with-libmaus2=${LIBMAUSPREFIX} --prefix=${HOME}/daccord

Still results in the error mentioned above.

Would be great if someone could give me a few pointers as to how to proceed.

  • Could you indicate the path where your libmaus2 is located and the PKG_CONFIG_PATH environment variable. – harrymc Sep 23 '18 at 17:38
  • libmaus seems to be in /usr/local/lib. I just now changed the PKG_CONFIG_PATH to /usr/local/lib. echo $PKG_CONFIG_PATH now results in /usr/local/lib. ./configure --with-libmaus2=${LIBMAUSPREFIX} --prefix=${HOME}/daccord or ./configure --with-libmaus2=/usr/local/lib --prefix=${HOME}/daccord both still result in "No package 'libmaus2' found". – BlindKungFuMaster Sep 24 '18 at 13:44
1

It seems to me that libmaus2 was not correctly installed, so you might need to really install it after all.

I'm not a user of libmaus2, but I did notice that it says that you need to provide the libmaus2 base directory when calling configure for a dependent.

Meaning that if you configured libmaus2 with :

./configure --prefix=${HOME}/libmaus2

then you might use for building the dependent package :

./configure --with-libmaus2=${HOME}/libmaus2

I also have no idea whether libmaus2 is built by default with support for the GMP library, but this might be a config parameter that you can check.

EDIT: Daccord is finally running after some help from the author. Here is how:

First, gmp had to be given the libmaus2 path:

./configure --prefix=/usr/local
make
make install

Then libmaus2 had to be informed about that too:

./configure --with-gmp=/usr/local --prefix=/usr/local
make
make install

Then daccord could be installed with:

./configure --with-libmaus2=/usr/local --prefix=${HOME}/daccord
make install

And, all that has to be done with the newest release version of both libmaus2 and daccord, which are not hosted on github, but on gitlab.

  • As I said, I'm not a user of libmaus2. If this answer doesn't help you advance, let me know and I'll delete it. – harrymc Sep 24 '18 at 14:03
  • Ah, well, first of all, thank you for your answer. I contacted the author and made some progress, but it doesn't run yet. I think you deserve the bounty for at least trying to help me out. I will probably edit your answer once I know the actual solution, if that's ok with you. – BlindKungFuMaster Sep 30 '18 at 5:46
  • @BlindKungFuMaster: Which bounty ? – harrymc Oct 1 '18 at 20:01
  • Did you not get it? I guess I had to accept the answer? I thought if there is only one answer it'll go to that one. I guess I'll bounty some more. – BlindKungFuMaster Oct 1 '18 at 20:44
  • Ok, further bounties don't work because apparently bounties need to double every time and I'm 37 rep short of that right now. So sorry, seems like I wasted your time and my rep. – BlindKungFuMaster Oct 1 '18 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.