0

I bought a new laptop from Dell with Windows 10 Pro. It had a BitLocker encryption enabled by default, but it was suspended. I activated the protection and saved the recovery key.

Then i installed Ubuntu 18.04 and edited the grub entry to make Windows default. Since then automatic unlocking stopped working and booting to Windows would ask me to enter recovery key every time.

I tried the following advices:

  • suspend the BitLocker and activate it again
  • delete TPM protector and generate a new one
  • check if UEFI, SecureBoot and TPM 2.0 are enabled in BIOS

But none of that worked, it still asked me for recovery key.

I also wanted to try to completely disable BitLocker and decrypt the drive and then encrypt it again, but when re-enabling it i got this error:

enter image description here

So UEFI boot mode is enabled, SecureBoot is enabled, TPM 2.0 is there and enabled, the disk has GPT (and not MBR), but i still can't use BitLocker with automatic unlocking. Why??

Isn't it possible to use BitLocker and custom bootloader (such as grub) at the same time?

1 Answer 1

0

I came across this issue by accident searching for a solution not to enter the recovery key every time I use GRUB as Bootloader to load Windows. The current state is, that Bitlocker works as expected if botted by the Windows Bootloader and if booted via GRUB I have to use the recovery key, even after first entering the valid PIN.

There I also realized that Bitlocker can't be activated if Windows was booted with GRUB. I was only able to activate it after using the Windows Bootloader.

A short detail for my setup. First was Windows installed, Linux after it. Every system is installed at a separate HDD, so every system has it's own running and not overwritten bootloader. This enables me to utilize the UEFI boot selection as bootloader.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .