1

I'm trying to access devices by using their hostname, like ping hostname, however since I switched to archer C7 I can't do that.

I tried to enable DNS service how I can't find it in the UI. It is also important to notice that I need to resolve hostnames from any device therefore adding the device to the hosts file isn't a solution.

I'm willing to install custom firmwere.

0

Man this has driven me nuts all week. I realized today, it looks like an issue with wired versus wireless - and that the Archer C7 is assigning IP4 addresses to wireless, and IPv6 to wired. I suspected it was having an issue with the routing internally.

Anyway, give this a shot: Go to your router settings Go to IPv6 support Disable IPv6 for WAN (to the internet)

Additionally: I also cleared out the default domain

I suspect that WAN connection is trying to do some resolution against your internet DNS instead of internal. Changing that for some reason seemed to fix it. Cheers

| improve this answer | |
  • Actually it has nothing to do with IPv6, C7 simply does not have the DNS server to resolve hostnames. You probably revert unnecessary changes to your router. I came across 2 solutions: flashing custom firmware or making a DNS server. If you have raspberrypi I recommend using pi hole as both DNS and DHCP servers because it simply works and very easy to maintain. – Adam Katav Oct 7 '18 at 9:01
0

After contacting TP-link support I was told that the C7 doesn't support hostname resolution.

Other options are installing custom firmware or using a DNS server. I use pi hole.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.