37

After I have installed Office 2016 Home and Student (en-us version) it automatically added two new keyboard layouts - English UK and English International in addition to my existing other layouts (English US and Russian). I'm trying to get rid of these new keyboard layouts but I absolutely cannot find an option to remove them ANYWHERE - not in Control Panel, not in Settings...

I have no "languages" section in Control panel, no "choose your langauge preferences" or whatever. In the new Settings thing these new languages are not shown in the list of languages, I can't remove them!

Does anybody know how to remove these new keyboard layouts? And why did Office add them in the first place?

Screenshots of my settings:

enter image description here enter image description here enter image description here

None of these solutions worked for me:

Remove automatically added keyboard inputs and prevent them from coming back (Windows 10)

2
  • If anyone still finds ENG-International keyboard layout returning constantly after triggering a certain hotkey, the easiest workaround (not a solution) is to press WinKey+Spacebar. This will cycle through all available keyboard layouts enabled on your machine, and you can easily switch out to the right ENG keyboard layout. Aug 11, 2019 at 18:43
  • Does this answer your question? How to delete a keyboard layout in Windows 10 Oct 17, 2020 at 4:50

3 Answers 3

27

If you cannot find these languages under PC Settings > Time & Language > Region & language > Languages, use regedit to navigate to HKEY_USERS\.DEFAULT\Keyboard Layout\Preload.

You will find there the list of keyboards that are preloaded at boot. Find the added keyboard layouts by their identifiers from the list of Keyboard Identifiers, and delete them.

Just in case, export this registry entry as backup.

EDIT: A more comprehensive answer can be found here.

7
  • 1
    Yeah, I've tried that, this key gets re-created after reboot, can't delete it forever it seems
    – szx
    Sep 23, 2018 at 11:01
  • 3
    I managed to finally get rid of these keyboard layouts by setting the values under Preload key to 0. I'm not sure why this worked. Since then they have been changed back to some other non-zero values but I haven't had this problem again. So I guess this answer can be accepted.
    – szx
    Oct 8, 2018 at 8:53
  • 7
    @harrymc I'd like to add just one thing - editing HKEY_USERS\.DEFAULT\Keyboard Layout\Preload didn't help me, but editing Computer\HKEY_CURRENT_USER\Keyboard Layout\Preload did help. I thing it would be nice to include this into your answer as this may help as well. Jul 4, 2020 at 8:53
  • 1
    @szx: Thanks, setting them to 0 worked for me! Let's see how persistent this will be for me. Nov 15, 2020 at 18:41
  • 1
    12 days (and a reboot) later, the solution in szx's comment is still working fine :) Nov 27, 2020 at 6:47
30

I had a similar problem to the OP: for the English language, I had US, Canadian Multilingual Standard as well as Canadian French as keyboard layouts and I could not remove the last two.

As I do not have administrator rights on my work PC, I could not use @harrymc's solution by editing the registry but I am able to edit language options. I tried the following and it worked for me:

  1. Add the extra unwanted keyboard layouts using the PC Settings > Time & Language > Language menu so they're all actually listed.
  2. Save.
  3. Afterwards, come back to the Languages screen and remove the extra layouts.
  4. Again, press Save.

I'm not quite sure how nor why but now those extra keyboard layouts are gone.

EDIT: I'm not sure if it's new or it existed when I added that solution but this solution does not persist through reboots.

4
  • 3
    This should be marked as an answer. In addition I had do add all keyboard layouts for unwanted Languages in my settings according to what was listed in my Language Bar - English (United Kingdom) - English US then set Windows Display Language to English (United States) and then I've removed English (United Kingdom)
    – Tomas
    Jun 5, 2021 at 20:03
  • 1
    In Windows 10 21H1 there is no Save button in those Settings pages. It seem to save immediately when you change anything. Nov 11, 2021 at 9:23
  • this answer work to me וp to now, but now is stop work
    – izikf
    Mar 28, 2023 at 7:20
  • This helps till the next restart of Windows. Aug 13, 2023 at 19:18
0

In my scenario, I'm on an English (GB) language-pack and locale PC, but I want the English keyboard to be only United States-International.

I found this article which along with @harrymc's answer solved the issue.

  1. Add and remove all redundant keboard layouts

  2. Override input method (PS):

    Set-WinDefaultInputMethodOverride -InputTip "0809:00020409"
    

    Substitute 0809:00020409 with the desired keyboard layout from this list.

  3. Add a new DWORD key named IgnoreRemoteKeyboardLayout under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout, and set its value to 1.

  4. Reboot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .