0

Here's where I'm having issues with input.

What I'm experiencing: Mouse input for dragging will not register. My Cintiq Touchscreen WILL interact with it. I've verified with other users on other OSs and browsers that this does function correctly.

Current things I've tried to troubleshoot:

  • Disable all Chrome extensions
  • Clear cache
  • Reinstall Chrome
  • Sign into different accounts on Chrome
    • Tried Incognito and Guest as well
  • Turn off my Cintiq Touch
  • Disable AntiMicro, an input remapper
  • Restart computer

Nothing useful is showing up on the console. If there's a means to see if mouse input is registering,specifically dragging, I've not figured out how to do it, yet. I was able to test clicking with:

monitorEvents(window, "click");

--which does register properly in the draggable areas.

I tested another javascript app (and this one) to see if all JS is affected, and that turns out to be false. My question is:

What else can I do to troubleshoot this problem?

Long-time reader, first-time poster. If I didn't post or format my question correctly I sincerely apologize!!

closed as too broad by fixer1234, jww, PeterH, Toto, music2myear Oct 8 '18 at 16:48

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to the posting side. The site is really designed to handle questions that have a specific answer. "How to troubleshoot" questions are open-ended and hard to answer within the constraints of the site's Q&A format. I suspect this will get closed, but perhaps people will suggest helpful guesses and things to check. – fixer1234 Sep 24 '18 at 2:52
  • I was concerned about that. I resisted asking Quora as it would likely not even have been commented on. Any other recommended resources? – David Montoya Sep 24 '18 at 21:05
  • See what suggestions you get here. Google does have a support forum: support.google.com/chrome/?hl=en#topic=7438008. I put in "mouse problems with javascript app" and this page of search results came up: support.google.com/chrome/… – fixer1234 Sep 24 '18 at 21:34
1

I found a short-term solution and likely cause of my problem. If anyone else has touch hardware on non-mobile, that would help verify. It looks like this JS app doesn't like the touch events API in Chrome. I disabled it in chrome://flags and now it's working.

chrome://flags/#touch-events

  • Kudos for finding a solution, and thanks for posting it. – fixer1234 Sep 24 '18 at 21:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.