4

In the past, I could refuse to sign in to chrome - and still be able to use, for example, gmail. I would just select the tiny "skip" link when presented with the sign in window.

With the latest version of chrome it seems this option has been removed. Now as soon as I sign in to gmail, chrome automatically signs in as well into the same account. If I sign out from under "people" in chrome settings, I am automatically signed out from gmail.

I do not want to sign in to chrome; I do not want chrome to associate everything I do in my browser with my account. Yet, I do have to use gmail and docs (it's a corporate account, I don't have a choice).

How can I keep using gmail without signing in to chrome?

  • You can access Gmail without sign-in to Chrome. I guess your account is saved on Chrome. Try to disconnect in google.com. – harrymc Sep 24 '18 at 9:50
  • @harrymc I did try that. As soon as I sign in to gmail, chrome 69 automatically signs in as well. As soon as I sign out from chrome, I am also kicked out from gmail. I believe this is a new thing in chrome 69, as version 68 didn't have this "feature" – Aleks G Sep 24 '18 at 9:51
  • You are right! Unbelievable. A solution might be to use an Incognito mode session for gmail, as this is supposed to leave no traces. – harrymc Sep 24 '18 at 10:21
  • I don't want to use incognito mode for most of the day. Remember, this is a corporate account, so I'm using google apps (gmail, docs, etc.) pretty much all day long – Aleks G Sep 24 '18 at 10:22
  • What about starting Chrome twice with two different profiles? And are you in Windows? – harrymc Sep 24 '18 at 10:28
4

After so much wasted time, I found the answer in this blog post:

https://news.softpedia.com/news/how-to-disable-the-auto-sign-in-feature-in-google-chrome-69-522856.shtml

Navigate to chrome://flags/#account-consistency and switch the Identity consistency between browser and cookie jar flag to "Disabled". Relaunch chrome - and you're set.

4

In Chrome 70:

Go to > Settings > Advanced > Privacy and security and disable Allow Chrome sign-in.

Allow Chrome sign-in
By turning this off, you can sign in to Google sites like Gmail without signing in to Chrome

Now, when you sign in Gmail, it won't sign in Chrome.

0

Another way to avoid Google forcefully signing users into Chrome is to use Ungoogled Chromium.

See the article Google is forcefully signing users into Chrome.

0

Chrome doesn't sign you in when you log in to Gmail, it just detects that you're signed in and displays your account picture. It was verified by Polish website Niebezpiecznik. They have tried to sign in to a fresh install of Chrome on a pristine OS. My rough translation:

On our office computers, even though our Google avatars appeared in the top right corner of browser's window, we weren't automatically signed in into Google accounts:

Expanded sync panel of Google Chrome, with user photo displayed but covered manually, and "Sign in to Chrome" button visible

So we've checked everything on a fresh install of Google Chrome on a clean OS and we've confirmed that when user signs in eg. into Gmail, they won't be signed in into Google Chrome until they click "Sign in to Chrome" and enter their Google accout password again.


To confirm their results, I have just installed Windows 10 in a virtual machine. Then I installed latest Chrome, navigated to gmail.com and signed in. Results:

  • I'm signed in to all Google sites
  • Chrome is showing my picture in top right corner
  • When I click it, it indeed looks like I'm signed in
  • But it's just misleading design - the large blue thing is a button that turns on sync
  • Settings actually look a bit clearer, there's also a blue button there, but it's smaller
  • Clicking the blue button enables sync. Until then, it's disabled.

Avatar menu just after signing into Gmail, with the misleading blue button visible:

Avatar menu just after signing into Gmail, with the misleading blue button visible

Settings just after signing into Gmail, with account name displayed, but with a smaller "Sync as [Your Name]" blue button:

Settings just after signing into Gmail, with account name displayed, but with a smaller "Sync as {Your Name}" blue button

An "You've turned on Sync" confirmation dialog that appears after clicking either blue button:

An "You've turned on Sync" confirmation dialog that appears after clicking either blue button

  • This is exactly what it was until version 69. Wtih version 69, it actually does sign you in - do test it yourself. Also read the blog article that I linked from my own answer. – Aleks G Sep 25 '18 at 8:21
  • Second paragraph from your link: "[...] being shown as logged into your Chrome's account in the browser's interface does not mean that the Sync service is turned on allowing the browser to send browsing data to Google's servers". So as I said, it just detects that you signed in, but it doesn't affect anything. – gronostaj Sep 25 '18 at 8:41
  • If you actually test it, you'll see what happens. After I sign in to gmail, if I then navigate to chrome settings -> people, I am shown as signed in to chrome. I have an option to sign out - if I do that, I get signed out from gmail as well. As I said, just test it yourself. – Aleks G Sep 25 '18 at 9:01
  • Also, see this - theregister.co.uk/2018/09/24/google_chrome_auto_login – Aleks G Sep 25 '18 at 12:26
  • And again, the tweet embedded in that article says it all. It's just an indicator that you're signed in on Google websites. It doesn't enable anything extra in Chrome itself. – gronostaj Sep 25 '18 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.