1

Here's my Dockerfile with instructions that all work except for the last line:

RUN echo http://nl.alpinelinux.org/alpine/v3.5/main > /etc/apk/repositories; \
    echo http://nl.alpinelinux.org/alpine/v3.5/community >> /etc/apk/repositories; \
    echo @testing http://nl.alpinelinux.org/alpine/edge/testing >> /etc/apk/repositories; \
    echo @edgecommunity http://nl.alpinelinux.org/alpine/edge/community >> /etc/apk/repositories; \
    echo @edge http://nl.alpinelinux.org/alpine/edge/main >> /etc/apk/repositories

RUN apk update
RUN apk upgrade
RUN apk add --upgrade apk-tools@edge
RUN apk add nodejs
RUN apk add npm

Prints:

ERROR: unsatisfiable constraints:
  npm-8.12.0-r0:
    masked in: @edge
    satisfies: world[nodejs-current-npm]

I check Alpine package respository, and it's there: http://nl.alpinelinux.org/alpine/edge/main/x86_64/ and in the main repository site: https://pkgs.alpinelinux.org/package/edge/main/x86/npm

What's going wrong?

1
  • Oh, didn't notice this. The docker image where I want to install this, comes from OSRM (osrm-backend), so I have no control on its version, and would like to stick to their original image. – culebrón Sep 25 '18 at 8:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.