5

I use CTRL+SHIFT on both Linux and Windows to switch between input languages. Under Linux the switch is always instantaneous, meaning a quick and light touch of the CTRL+SHIFT combo suffices - I don't have to hold the key combo down or to press it several times until finally the switch successfully occurs. This is regardless of what applications I am running at the moment.

This is not the case in Windows. I often find myself having to press the CTRL+SHIFT combo several times or to hold it down until the input language is actually switched. While I cannot always reproduce the issue, I have noticed that for example it often happens when I am using a browser - maybe because I then switch the languages more frequently, for example due to chatting with different people in facebook or similar. Also, I am pretty sure that I don't have a stuck key on my keyboard.

I had this problem in Windows 7 as well but never looked into it. I believe I was able at some point to figure out how to fix this in Windows 10, but after some 'quality updates' (that probably reset some stuff in Windows 10 anyway) I cannot pinpoint the relevant settings. My guess is that it has something to do with how Windows treats sticky keys and key combos, which itself has probably changed since.

Personally, I find that latency unnecessary and even annoying.

Current OS: Windows 10 x64 (1803)

Does anyone know how to remove or reduce the delay of switching between input languages in Windows 10?

Feel free to add more relevant tags.

EDIT: Sticky keys and Filter keys are off in the Settings panel.

9
  • Go to Settings->Time&Language->Region&language->Advanced keyboard settings->Language bar options->Advanced Key Settings->Change Key Sequence. Then you can see two different options: Switch Input Language and Switch Keyboard Layout. Switch Input Language switches between different languages in the same input method. Switch Keyboard Layout switches between different input methods. Make sure that the shortcuts are set under both tabs and that the shortcuts you set are different. Then use different shortcuts to switch between language categories or input methods to see if the issue is resolved.
    – S.Leon
    Sep 26, 2018 at 6:52
  • 1
    @S.Leon: that's how I have set CTRL+SHIFT to be my shortcut for switching input langauge instead of switching keyboard layout in the first place.
    – M.G.
    Sep 26, 2018 at 12:05
  • 1
    Change this shortcut to see if this issue still occurs.
    – S.Leon
    Sep 27, 2018 at 3:25
  • @S.Leon: OK. I switched back to the ALT+SHIFT combo for changing the input language. The issue does not occur with this shortcut, thanks! The keyboard layout shortcut is still left unassigned. So, any idea what's causing it? I would like to have the same responsiveness from the CTRL+SHIFT shortcut.
    – M.G.
    Sep 27, 2018 at 3:36
  • 1
    @S.Leon please post your solution as an answer, now that you know it works :)
    – bertieb
    Sep 28, 2018 at 6:50

4 Answers 4

4

Go to Settings->Time&Language->Region&language->Advanced keyboard settings->Language bar options->Advanced Key Settings->Change Key Sequence.

Change the shortcut below Switch Input Language to see if this issue still occurs.

Nowadays,the default shortcut to switch input language of computers running Windows 10 is so strange. Some are left Alt+Shift, some are Ctrl+Space, and some are even Windows+Space. Then, some shortcut keys work fine, and some shortcut keys have a high delay. And I am not very clear about what caused this.

Also, switching the input language will have high latency when the memory is too high (of course you might have considered this).

2

In my case the cause was several English languages added to the list of languages in the system. As soon as I removed all but one the delay vanished.

1

I recently changed to Windows 11, but in case it works for anybody else (since I think Win 10 and Win 11 are mostly the same when it comes to the language bar?) and had the issue where I had to keep holding down the Win key in order for the language bar to appear. I went to Settings->Time&Language->Typing->Advanced keyboard settings->Language bar options. Then fiddling with the options in the Language Bar box seems to fix my problem. It doesn't seem like I had to change it to any particular setting, I think just the action of changing the settings at all fixed it.

The language bar still takes a while to appear, but the layout switches instantly.

It could be a coincidence for me, where time solved my issue and not messing with the settings per se.

1

Seems like the correct answer should be the following:

Go to the registry key:

HKEY_CURRENT_USER\Control Panel\Accessibility\Keyboard Response

And have this parameter changed DelayBeforeAcceptance from the default 1000 to something quite smaller, like 200 or even 50. See if it helps.

For me it helped, but now the Windows 10/11 language switch bar label sometimes will just keep hanging around until I click on it:

Lang bar hanging

Update

I do also have to add that doing that and rebootig DID NOT work out for me. Seems like nothing's changed even. Too bad for me.

I was too soon to write "it helped". It indeed helped in that very same RegEdit window (with the hanging bar sometimes), but as soon as I focused another window, it returned back to being laggy. Seems the problem only became more deep and difficult.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .