0

I have a local Network with a Window 10 computer and a Windows 7 computer. Both have the same Network Settings (visible to other computers, etc.). On the Windows 10 computer, I can see both the Windows 10 computer and the Windows 7 computer in the Windows Explorer Network Group, but on the Windows 7 computer, I don't see the Windows 10 computer.

The Windows 10 computer runs Windows 10 Pro, Version 1803, Build: 17134.285

The Windows 7 computer runs Windows 7 Home Premium, Version 6.1, Build 7600

Each computer sees each other.

On Windows 10 I have shared a folder with "Anyone". I've made sure that it's not write-protected. Permissions are "Full".

SBM1_protocol is disabled on Windows 10.

I can see this folder on the Windows 7 machine's Explorer, but when I double-click it, Windows 7 tells me "You don't have permission to access… Contact your administrator..."

On Windows 7, I can see that the Window 10 machine's "Users" folder is also shared. I can double-click this. It doesn't show any files, but I don't get the above error message.

I have started the Windows event viewer on both computers, navigated to "Windows logs" and erased all logs and then double-clicked the folder in Question again. Then I clicked "Refresh" on all log panels, but none of the event viewers showed any message after access was denied.

What could I check next?

Thank you!

Edit: I have uploaded a screenshot that shows what Microsoft Network Monitor 3.4 tells me. Is there anything helpful to see?

https://i.postimg.cc/L4QJFT9M/nm1.png

  • Just log on the windows 10 locally and right-click the User folder, then open properties, and security to see if the user you log on the windows 7 have the permissions. If you don't have the permissions, just add the permissions for the user. – OOOO Sep 26 '18 at 6:29
  • @OOOO Permissions read-write-full are set for "Anybody" / "Everybody" (not sure what the correct term in English is) for that folder. – AntonioC Sep 26 '18 at 10:31
0

Wasted quite a bit of time on this, as I have with so many stupid Windows issues. It's not enough to just allow "Everyone" or any particular user(s) in the sharing dialog, you have to do so in the security settings for the drive/folder as well. When you're in the properties, set up the sharing tab, then go to the security tab and make sure the user(s) that need access are set up there as well.

IMO, the "Give access to > Advanced sharing..." entry in the context menu shouldn't even be there, since it just clutters the menu, is completely unnecessary since it just opens the properties window, and is misleading, making you think that's all you need to make sharing work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.