21

I am trying to start a Ubuntu (64-bit) Linux VM from VirtualBox (5.2.18 r124319 (Qt5.6.3)) on macOS High Sierra (10.13.6 (17G65)) running on a 2016 MacBook Pro 15"

The MacBook Pro in question is recently restored using my Time Machine Backup. I have enabled FileVault on the original MacBook Pro.

Here is the image of the error dialog box:

enter image description here

The text is:

Kernel driver not installed (rc=-1908)

Make sure the kernel module has been loaded successfully.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

I have enabled disk level encryption when I set up the Linux VM.

Here is some more details of the VM

enter image description here

It is what I picked up from the system.log

Sep 26 10:15:44 konga-mbp-loaner com.apple.xpc.launchd[1] (org.virtualbox.startup[95]): Service exited with abnormal code: 1

What I tried after the Linux VM failed to start:

  • I tried to reinstall VirtualBox but the installation failed.
  • Restart the machine and try reinstall again, also failed.

enter image description here

7
  • The reinstallation of VirtualBox failed or of the VM after reinstalling VirtualBox? Sep 26 '18 at 1:00
  • The reinstallation of VirtualBox failed. VM failed to start even before the attempt to reinstall VB Sep 26 '18 at 1:17
  • And the error (rc=1908) is popping up when? Sep 26 '18 at 1:19
  • At the very beginning when I simply wanted to start the linux VM. Sep 26 '18 at 1:19
  • So your problem now is not a failed VM, but a failed VirtualBox installation, so you should try to resolve that first. (It could be, that I'm completely missing the point of the question) Sep 26 '18 at 1:22
16

MACOS Catalina 2020

Run following command and to clear vmBox

sudo kextcache --clear-staging

after that reinstall virtualBox and go to your Preferences --> security & privacy -->select General

you will see a allow option there you have to allow that .

NOTE:- that allow option will be there only for 30 min after you installed VMBox, otherwise you have to do install again.

12

Basically it is because Apple has blocked some extensions from loading. After unblocking them I can reinstall VB as expected.

enter image description here

5
  • 2
    I'm having the same problem, but I have no Allow... button in my Security & Privacy dialog, I've unlocked with the superuser account, I've uninstalled VirtualBox several times and tried again, no luck...what can I do?
    – SPlatten
    May 14 '19 at 10:14
  • Did you pick the 'App Store and identified developers' option under 'Allow apps downloaded from:'? May 14 '19 at 10:44
  • Sorry, yes, please take a look at my post superuser.com/questions/1436347/…
    – SPlatten
    May 14 '19 at 10:47
  • That button appears in the system preferences during the installation of virtual boz Jun 24 '20 at 5:28
  • To be precise, you have 30 minutes from the time of install to press "allow". If you install with that box open, the option won't show up. You'll have to reopen the panel to see it. Jan 12 at 23:15
2

FWIW, on the latest version of MacOS (Big Sur) I simply had to update VirtualBox to the latest version (and allow the security control mentioned above). Without upgrading I never saw a security control block.

2

I've had VirtualBox installed before but after an Upgrade to Mac OS 11.6 VirutalBox stopped working. Reinstalling VirtualBox didn't help. I also didn't see any option in the Security & Privacy pane.

Finally, this was the only solution that worked for me: https://ilgthegeek.wordpress.com/2018/01/27/macos-install-oracle-virtualbox-on-10-13/

Reboot your Mac into Recovery Mode, then type:

spctl kext-consent add VB5E2TV963

VB5E2TV963 is Oracle's Developer ID

1
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Oct 2 at 18:26
1

COMMENTING INCASE ANYONE SEES THIS THREAD AND NEEDS HELP IN THE PRESENT.

I would get the same install error. I decided to open the application anyways to see if I could figure more things out. I could open the application and make new systems, but when trying to open and install those systems I would get a Kernel Driver Not Installed rc =- 1908 error.

I did every step I could find on these threads, updated computer (MAC High Sierra 10.13.6), temporarily disabled security preferences through terminal, deleted installer and application and tried other previous downloads for VirtualBox. The fix was so easy in the end!

It was a "kernel" error, so when installing VirtualBox I clicked "customize" instead of the regular install. You will see multiple things checked off that is included in the standard install. Just click on the one that has "kernel" in the name so it is highlighted, and then the install button on the bottom right. For some reason it was not installing the Kernel Driver with the package, despite it being selected to install. I just had to single it out!

Hope this helps another struggling Mac user. I really need to get a new computer lol

0

Make sure that you move the old .app to trash before re-installing virtualbox. Check Security & Privacy as mentioned by others in case it was locked out by the system.

Not the answer you're looking for? Browse other questions tagged or ask your own question.