1

This question already has an answer here:

I have a minilaptop which shift keys do not work. I want to remap the layout so when I press CapsLock key it behaves like shift. I have seen many turials on this matter but most of them are either too broad or too specific, and I have not been able to solve this problem.

My minilaptop runs Ubuntu 18.04 with the LXDE desktop.

Edit: issue solved!

Answer below.

marked as duplicate by Toto, G-Man, Pimp Juice IT, Kenneth L, Attie Oct 3 '18 at 15:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • No, in that post the OS is really really old, my desktop environment does not have a way to set up keyboard layout in preference and xmodmap is no longer supported by Ubuntu since 2013. Thanks anyways. – egroj97 Sep 26 '18 at 4:51
0

Its kind of messy, but first, read your keyboard manual entry keyboard(5). That's so you can get a general understanding of how it works. Then look for the keyboard file. (In my PC it was at /etc/default/keyboard) and spot the XKBOPTIONS line. Then look for the base.lst file, in which all available options are listed with a description of how they work. (In my pc I founded it at: /usr/share/X11/xkb/rules/base.lst) Spot the one that you need and try it in the XKBOPTIONS line in the keyboard file. Save as root and then do:

sudo dpkg-reconfigure keyboard-configuration

and problem solved. The option that worked for me as a "Sticky Shift" was caps:shiftlock

Not the answer you're looking for? Browse other questions tagged or ask your own question.