0

I am totally stumped by this and have done this many times successfully in the past.

I create a parent disk (Windows 10 build 1607, have to use this old build for testing purposes) and then a differencing disk against this parent using Hyper V using methods such as described here:

https://msitpros.com/?p=3735

https://www.altaro.com/hyper-v/hyper-v-differencing-disks-explained/

When I start the diff disk vm for the first time I get a black screen with blinking cursor.

In desperation I tried this

http://www.etdot.com/2012/02/29/felipe-binottos-blog-windows-wont-boot-black-screen-with-blinking-cursor-at-the-corner/

and it seems that no C drive is available when I go to the command prompt. This sound like it would be part of the problem (obviously).

Any ideas why this would happen? I have googled around and people have various problems with starting the vm and hitting a black screen but none of them work for me.

FYI trying to debug the issue in any way I could I found that pressing F8 (after adding the hyper v delay) during boot does not get me to any BIOS menu.

Thank you for any help m

0

For anyone who has a similar issue in the future I describe what worked, though I don't know why.

I was creating my parent disk on an UN-PATCHED (i.e. no updates applied) version of Win10 1607.

Recently I applied all patches (as of 28 September) to the parent disk (Windows 1607), sysprepp-ed it and created a new child diff disk: this worked.

I guess something in one of the patches must have fixed the issue? I don't really know.

m

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.